We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Stuttering / buffering when watching HD+ on Chili

Conversation Starter
Message 3 of 3

I have ethernet connections (cat6) between the Talk Talk router > powerline adapter and powerline adapter > TV.


When I stream Chili movies on an LG Smart TV using the Chili App, I am unable to watch HD+ format movies due to buffering and action sequences having a 'lag' effect every few seconds. It is better in HD, but to get the smoothest performance I have to drop down to SD.


My connection is @ 35MBps which is the bare minimum and I was getting at least 40MBps when I first joined Talk Talk.


Chili state the following speeds are required for streaming:

- SD: Standard Definition. format of 720x576 pixels. To watch in streaming, an internet connection of at least 1Mb/s bandwidth is needed.

- HD: High Definition, format of 1280x720 pixels. To watch in streaming, an internet connection of at least 2.5Mb/s bandwidth is needed.

- HD+: High Definition Plus, format of 1920x1080 pixels. To watch in streaming, an internet connection of at least 4.5Mb/s bandwidth is needed.


Is there anyone who can reset/tune my router so that the performance is more acceptable? I don't want to have an engineer visit (tried that and he just said to contact Talk Talk if problems continue). Online chat just want to book an engineer visit and can't seem to do anything useful or unscripted due to lack of knowledge/permissions.





Popular Poster
Message 1 of 3



I feel your pain.  I have a direct ethernet connection (CAT5e) and I still get buffering/glitching at times.  I would think you'll stand a better chance without the powerlines, but there's something dodgy going on anyway.


I'd be interested if you have the issue with any other streaming services, as Chili is the *only* one I have any problems with.


My average download speed is around 54 Mb/s, so I'm fairly sure it's not bandwidth related - if I run a speed test around when the issues occur, I get 50+ Mb/s.  


My Chili movies are effectively free through Vodafone rewards, but I won't give them any money as the service just isn't reliable enough for my liking.




Community Star
Message 2 of 3

I would try a direct ethernet connection first to identify whether the issue lies with the powerline adapters.