Showing results for 
Search instead for 
Did you mean: 
Need help?

Want to know how to get the most out of our community?

Hey, I'm Michelle and I wanted to tell you about our community and how it's packed full of useful information, answers and has a horde of active members waiting to help or just to say hey! We know forums can be a little daunting at times, so here are some of my useful tips to help you get the most out of the community:

Get Searching

Search is the quickest way to locate the information you're after, use the big red box above. If you don't find what you're after you can always post your own question.

Search now

Get stuck in

Prefer to jump straight into the community? Checkout the yellow "browse" tab over on the left hand side, here you'll find the entire community at your fingertips.

Try now

Join the party!

Had a peek around the community already? If so you'll no doubt want to join us, just hit register below and follow the instructions. Don't worry I'll still be here to help once you've registered.

Register now

Upload test error


Currently I'm getting "upload test error" on every speed test I try and the internet runs very slowly. File uploads (email attachments to Gmail, Hotmail etc) are impossible, though commands (navigate to another website) can be sent, albeit with slow response. Download speed is fine (c. 11MB on test).

You will see from the router details below that the upload and download speed are nominally fine, and line tests don't generally return errors.

It seems like a very unusual fault from asking various engineering students, and Fault Management hasn't been helpful. It does make browsing the internet very frustrating and slow, and I can't manage my personal website, because I can't upload anything to it (everything times out).

The closest Fault Management has come to identifying the issue, I believe, was on 30/03 where Richard found that while re-profiling the line (changing the frequency of the broadband), the port disabled to perform this would not re-enable, and he detected data sync issues, suggesting a faulty network card at the exchange. It was escalated to OpenReach who said they couldn't find any fault (how hard they tried, I question).

This is an old ongoing fault, since 25th February and I thought I'd post to see if anyone has any ideas what the problem is. I've tried all the usual things: plug router direct into socket, use ethernet cable, use another PC/laptop, swap router etc and none make any difference. The same result is obtained.

Required details:
1. What exchange are you connected to?
Guildford (THGI)
2. How many telephone extension sockets do you have?
3a. Do you have an NTE5 master socket?
No (there is an old ntl one across the room, but it's disconnected); never caused any problems before.
3b. If yes to question 3a, have you tried the test socket?
3c. If yes to question 3b, how long for and did you notice an improvement in your connection?
3d. Do you have an iPlate or ADSL faceplate?
4. Is your modem/router connected to your Master Socket?
No, as don't have a Master socket
5. Are you experiencing any problems with your phone service?
No, all fine
6. What modem are you using? (Make & Model)?
Huawei HG533
7. Have you tested with an alternative modem? (Make & Model)
Yes, Huawei HG520
8. Have you tested with a different microfilter?
Yes, was sent a new router
9. Are you using a telephone extension lead?
Tried both with and without
10. What is your modem SNR Margin down and up?
SN margin (dB): up 9.1 down 7.1
11. What is your bandwidth (Connection or sync speed) down and up?
ADSL line speed (kbps): up 847 down 12435
12. What is your attenuation down and up?
Line attentuation (dB): up 15.5 down 28.0
13. Are you experiencing the disconnections at any specific time?
14. Are you currently using Wireless?
Both Ethernet & Wireless
15. Do you have an Alarms and/or Sky boxes connected to the telephone line?
Community Team
Hi Mark000,

I have completed a line test which has not detected a fault on the line. Are you trying to run the speed tests on the members site? Have you also tried running the speed tests in safe mode with networking to see if the speed test completes?

Ive tried multiple test sites: members site,, etc -all return the same result.

I've tried on two laptops, a desktop and an Android mobile with the same test results.
I'm not at my computer now, but fail to see how a safe mode speedtest would make a difference seeing as it's not my equipment (as multiple devices tried). (I will try when I get home though)

Line tests performed by TalkTalk never seem to return an error. Suggest you try a reprofile and see if enabling the port gives an error as per my OP
Community Team
Hi Mark000,

I have reset the data port and there are no issues showing. We will need to look into this as a speed issue. In order to raise the speed issue over to our Network Team for investigation, please can you run some speed tests on the members site in a wired state and in safe mode so we can see how the speeds compare.

Can you also run some pings and trace routes in a wired state and in safe mode to and post the results into the thread.

I've tried in safe mode with networking and got "upload test error" from the TalkTalk speed test as predicted.

I have performed a ping: 30ms
Tracert: 14 hops: 11 timed out.


Pinging with 32 bytes of data:
Reply from bytes=32 time=31ms TTL=46
Reply from bytes=32 time=30ms TTL=46
Reply from bytes=32 time=30ms TTL=46
Reply from bytes=32 time=30ms TTL=46

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 30ms, Maximum = 31ms, Average = 30ms


Tracing route to
over a maximum of 30 hops:

1 <1 ms 1 ms <1 ms
2 20 ms 20 ms 19 ms
3 61 ms 26 ms 26 ms
4 45 ms 23 ms 23 ms
5 24 ms 24 ms 25 ms
6 24 ms 24 ms 24 ms
7 25 ms 24 ms 25 ms
8 25 ms 25 ms 25 ms
9 * 31 ms 47 ms
10 68 ms 25 ms 25 ms
11 37 ms 36 ms 36 ms
12 36 ms 36 ms 36 ms
13 * * * Request timed out.
14 31 ms 31 ms 31 ms

Trace complete.
Community Team
Hi Mark000,

Thanks for the additional results. I have just started to raise this over to our Network Team for investigation, however I can see that an engineer visit has been arranged for 27th April. As you already have an engineer arranged we cannot raise this to our Network Team until the visit has been completed. Let us know how you get on.
No problem, will do
Community Team
Hi Mark000,

Thank you :)
Hi - just providing an update from the engineers visit this morning.

An engineer from Cube visited, did the usual checks (router, speed test, line test, network test) and confirmed a "throughput speed issue - upload sync". This has now been escalated to BT and an engineer may be calling in the next week.

Speed tests still give the upload test error, but line checks pass as does the network test.

The engineer said he'd seen the same issue only once before in his 6 months in the job, and it was a network issue which did eventually get fixed. He could tell there was an issue from how long it took to load webpages, and he had to use his mobile internet in order to display my details at one point.

Hopefully BT will fix the issue. I will keep you posted.

(NB: Underlying all this is that this case has already supposedly gone to the OpenReach team several times and they "investigated the line" and found no fault. I'm hoping that the Cube engineer's report coupled with me being asked to provide dates for an engineer this time means it will actually get resolved)
Community Team
Hi Mark000,

Ok thanks for keeping us updated and let us know if you need any assistance via the forum.