NEED SOME HELP?

We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Web pages are slow to load or won’t load

Nick_w
Popular Poster
Message 8 of 8

Hi I’ve had the Wi-fi hub now for almost 5 months and in those 5 months I have found certain web pages and apps on my phone take a long while to load whilst using the TalkTalk WiFi Hub. Over the weekend I swapped to A HG635 and everything runs fine reconnected to the WiFi router and it’s doing the same. The reason for reconnecting was by request of the TalkTalk tech advisor. Who in my eyes didn’t know what he was doing I wasted 2.5 hours on the phone going over the same things giving the same answers. I got onto the phone and spoke with the manager and talking to him wasn’t getting anywhere. All I wanted to do was have a new router sent out and myself send back the one I have. If things work fine on one router but not the other must be a router issue surely? 

0 Likes
7 REPLIES 7

Message 1 of 8

OK thanks, look forward to hearing from you 🙂

0 Likes

Message 2 of 8

Thank you very much for your speedy responses and your help. Wish I had spoken to the relevant people on here instead of wasting 2-3 hours talking to the supposed tech advisors over the phone. Do appreciate your time thank you again. I will notify once router has arrived and will update on the routers performance after a couple of days use. 

0 Likes

Message 3 of 8

Hi Nick_w,

 

I've ordered you a wifi hub, should be with you within a couple of days but please allow up to 5 working days for delivery


Thanks

Chris

 

 

0 Likes

Message 4 of 8

Can I have another Wi-fi Hub. The HG633 I’ve heard isn’t good. Thanks for your quick replies. 

0 Likes

Message 5 of 8

Hi Nick_w,

 

There is a new version of firmware for the wifi hub which is being tested at the moment, however we don't have a specific timescale when this will be available.

 

Would you like us to send a replacement router for testing purposes? We can either send another wifi hub or a HG633 router, which would you prefer to test with?

 

Thanks

 

0 Likes

Message 6 of 8

I’m using an iPhone 7 Plus over Wi-fi. Even when trying to load this site I had to refresh it. It does it also on my laptop which is windows 10 and that is a wired connection and when using a particular site whilst trouble shooting on the phone to TalkTalk that took a while to load. When using the HG635 I have no problems. Unfortunately the HG635 isn’t mine I borrowed it to see if things improved and they do. Going back to your question about that particular page loading. Sometimes it does but like yesterday it didn’t. Is there a firmware update for the WiFi hub? 

0 Likes

Michelle-TalkTalk
Support Team
Message 7 of 8

Hi Nick_w,

 

I'm sorry to hear this. We're currently looking into this with our Products Team. Just to confirm, does this only occur on this phone? Do the same sites load more quickly on a different wired and wireless device?

 

What phone are you using? (make and model) Does the site/app eventually load?

 

Thanks

 

0 Likes