cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Is there a SuperSafe software for older Macs? I have Yosemite 10.10.5

Reply
1 REPLY 1
HayleyBart
First Timer

Is there a SuperSafe software for older Macs? I have Yosemite 10.10.5 but I daren't download a newer version because my laptop is old. Do you have a SuperSafe which supports older Macs or is the SuperSafe not essential

Thanks, 

Hayley 

Gondola
Community Star

Hi @HayleyBart

 

For MAC's the SuperSafe Boost is compatible with the following:

  • OS X versions 10.13 (High Sierra)
  • OS X versions 10.12 (Sierra)
  • OS X versions 10.11 (El Capitan)
  • OS X versions 10.10 (Yosemite)
  • OS X versions 10.9 (Mavericks)

MAC System requirements:

  • Processor: Intel
  • Memory requirements: 1 GB or more
  • Disk space: 250 MB free disk space

So, yes, Supersafe boost is compatible with Yosemite 10.10.5 ...and it's better to be safe than sorry!

GondolaVolunteer 2017-2021

 Give Likes below to appreciate my help . . . and to help others Best Answer