TV Support

For help with your TalkTalk TV box, channels and apps.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixelation / loss of signal. Internet problems or Powerline Adapter problems?

jon_c78
Conversation Starter
Message 4 of 4

Hi, 

 

I pay £4 a month for my talktalk TV package.  

 

Correct me if i am wrong, but as i have a Samsung Smart TV (built in Apps, including Freeview),   I think the 'only' benefit i get by paying for TalkTalk TV  is Pausing Live TV ? Would that be correct?

 

I am currently having problems with pixelation and/or loss of signal on the HD channels.  

 

I cannot link my ethernet from the router directly to my TV  (its in a different corner and cant be routed), and so i use Powerline Adapters.  They intermittently flash red/amber when signal drops.

 

How do i diagnose whether the problem is TalkTalk's internet (and therefore cancel this £4 p/m service) , OR if it is  poor Powerline Adapters, poor ethernet cable , poor electric in the house, or some other fault other than the internet signal.

 

Thanks,

Jon

Jon
0 Likes
3 REPLIES 3

fre55die
Community Star
Message 1 of 4

Hi @jon_c78 

 

Well there appear to be a number of separate issues here.

 

1) Most current TV's have the facility to pause live TV and or record the channel being watched, this will need either a USB stick or external hard drive, this will only be for the channel BEING WATCHED as most TV's only have one tuner in them. Read the TV manual for instructions on which USB socket to use.

 

2) Is this pixellation/loss of signal on the TV or just the TTbox? It sounds like either an aerial problem, external interference from either something in your house such as a microwave or some other appliance, or the physical lead from the wall socket, so this needs checking out. A high quality properly insulated aerial lead is recommended and ensure that the connections are firmly into the sockets. All FREEVIEW channels are only received over your aerial. The other thing to try is to unplugging the aerial and doing a retune without it connected, this will show no channels found but, will clear the tuner memory. Plug in the aerial and retune again.

 

3)Power Line Adapters, the occasional flickering of the lights indicates a poor connection. Firstly try unplugging them all from the sockets for 15 minutes or so, then replug them in and turn the power back on. I have a pair that every few months or so do this and this cures them. If this doesn't get rid of this problem then a factory reset of the plugs is the next step. https://community.talktalk.co.uk/t5/Articles/Fix-a-problem-with-your-Network-Connectors/ta-p/2284111

 

Keep us informed of how you get on.

If this has helped and solved your problem, please mark it as "Accepted Solution" from the 3 dot dropdown menu in the bottom right of this post so that staff or others do not spend time looking for alternatives. If you like the answer please feel free to click the "Like Button"

jon_c78
Conversation Starter
Message 2 of 4

Great! I had some issues yesterday in verification. Ended up duplicating...

Jon

Gliwmaeden2
Community Star
Message 3 of 4

@jon_c78, I'll move this post to the TV section and move the duplicates out of the way.

 

I'll make sure that your topic is in the queue for attention. 

Gliwmaeden2, a fellow customer.