cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Amazon Prime player keeps buffering or "Something went wrong"

ANSWERED
Reply
8 REPLIES 8
Highlighted
Community Star

The Amazon Prime player on my TalkTalk TV Box keeps buffering when trying to watch a film or it displays an error "Something went wrong".

 

There seems to be other people suffering from this problem:-

 

https://community.talktalk.co.uk/t5/TalkTalk-TV/Amazon-Prime-on-TalkTalk-Box/m-p/2437972#M144398

 

https://community.talktalk.co.uk/t5/TalkTalk-TV/Amazon-Prime-Constantly-Buffering/m-p/2437180#M14431...

 

https://community.talktalk.co.uk/t5/TalkTalk-TV/Amazon-Prime-buffering-all-the-Time/m-p/2436648#M144...

 

https://community.talktalk.co.uk/t5/TalkTalk-TV/Amazon-Prime-Still-Buffering/m-p/2436290#M144223

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Star

Hey Keith, is it just Prime Video which is affected i.e. other apps OK? Is Prime Video working on other devices?

Highlighted
Community Star

The other players are fine, it only affects Amazon Prime. I haven't had a chance to try it on anything else as yet, but all the other people suffering from this, say it is fine on other devices, but not on the TV Box player.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Star

@KeithFrench 

 

Hi Keith,

 

As I reported elsewhere, I get the occasional freezing on my ROKU express on Amazon prime and watched about 2 mins of a frozen "The Marvellous Mrs Maisel" last night, so it's not just the TT boxes although it is rare.

If this has helped and solved your problem, please mark it as Best Answer so that OCE's or others do not spend time looking for alternatives.
Highlighted
Community Team - TT Staff
Solution

Hi

 

I've resolved this for a couple of customers in various ways, so I still have not identified what is causing this.  One customer was resolved via a firmware update to the router, and a couple of others have resolved this by a factory reset fron the settings menu. - I'm thinking it may be the app itself or something from the amazon end, but so far have drawn a blank, but I'm still digging.

 

Thanks

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


STAY HOME      -      PROTECT THE NHS      -      SAVE LIVES

Highlighted
Community Star

Thanks Karl, I'll try the factory reset on the TV box when I get some time.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Star

Hi @OCE_Karl 

 

The maintenance reset keep recordings worked. Out of interest, does the factory default from settings do the same thing?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Star

Hi @KeithFrench 

 

No it formats the hard drive so all recordings lost.

 

Happy New Year Keith

 

Tony

If this has helped and solved your problem, please mark it as Best Answer so that OCE's or others do not spend time looking for alternatives.
Highlighted
Community Star

Cheers Tony, glad I didn't do it that way hen!!!

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they?