cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

tv box not recording programes or playing previous recordings

Reply
4 REPLIES 4
keithj64
Sightseer

For a couple of weeks now our box has not been recording any program from any channel regardless of whether the box is on standby or actually on. It also will not play previously recorded programs, the time bar appears at the bottom of the screen and then the screen goes blank. I have read the replies to previous posts on similar problems and have tried the recommended soft reboot and full factory reset neither of which has solved the problem. Do I need a new box? Thanks, Keith.

OCE_Michelle
Community Team - TT Staff

Hi keith,

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

keithj64
Sightseer

Hi Michelle, as requested I have updated my profile. I have to say this system is not very user friendly. at no point does it make it clear what it expects from me ,the customer, and joining a 'community' of 'users' is the last thing I was looking for when trying to reach good old fashioned customer support to report faulty equipment! Maybe you could make the point to your bosses that we are not all tech savvy 20 somethings and that something simpler to use might be more appropriate. ie; I initially logged into my account, went to the help and support section, finally worked out that i had to 'post a topic', did so only to be told that it hadn't been accepted because I hadn't created a profile and logged in !?!?!?  Sorry to rant, thanks, Keith.

OCE_Debbie
Community Team - TT Staff

Hi Keith

 

Apologies for this.

 

I have ordered a replacement TV box and you should receive this within the next 48hrs.

 

Please let us know how you get on.

 

Thanks

 

Debbie

keithj64
Sightseer

Hi Debbie, New box arrived Friday, installed, set up and appears to be working fine. Thanks,Keith.