cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Supersafe Boost on HTC One X

Reply
10 REPLIES 10
ChrisFord
Enlightened One

I have just tried to install the new Supersafe Boost onto my HTC One X and the installation process tells me that:-

"This app is incompatible with your device".

I find this particularly galling as the mobile concerned was supplied to me by Talktalk mobile when I was asked to trial their mobile service!!!

 

Can I expect a solution??

 

Kind regards,

 

Chris

Anonymous
Not applicable

There are currentlly some "challenges" due to the release of a new version of SSB.

 

Not exactly the problem as described, but worth keeping an eye on this thread :-

 

http://community.talktalk.co.uk/t5/Current-Known-Service-Issues/SuperSafe-Boost/m-p/1848034#M235

 

 

ChrisFord
Enlightened One

@eebdsirhc wrote:

There are currentlly some "challenges" due to the release of a new version of SSB.

 

Not exactly the problem as described, but worth keeping an eye on this thread :-

 

http://community.talktalk.co.uk/t5/Current-Known-Service-Issues/SuperSafe-Boost/m-p/1848034#M235

 

Thanks for the "heads up" - I wiil wait and see what develops.

 

Chris

 

 


 

ChrisFord
Enlightened One

I have recently received an e-mail from Talktalk asking if I had got the answer I needed. Although I have had one comment on this thread (for which I am grateful) there has been nothing from an OCE or anyone else who can address the issue from a Talktalk or F-Secure perspective. Is the forum no longer seen as a conduit for user / OCE contact to deal with this sort of issue?

 

So, as far as I am concerned, and to date - I have not had an answer!!

Anonymous
Not applicable

OK - thread escalated.

ChrisFord
Enlightened One

@eebdsirhc wrote:

OK - thread escalated.


 Once again, many thanks.

OCE_Chris
Community Team - TT Staff

Hi Chris

 

I'm sorry to hear that you are experiencing problems with the supersafe boost 

 

Which version of Android is your HTC currently running?

Chris

ChrisFord
Enlightened One

Hi Chris,

Android 4.2.2

Kind regards,

Chris

OCE_Debbie
Community Team - TT Staff

Hi Chris

 

Apologies for the delay.

 

SuperSafe should work for all Android Devices running version 4.0 or up. So running on this HTC shouldn’t be a problem.

 

Just to confirm, are you installing the new SuperSafe boost? https://play.google.com/store/apps/details?id=com.fsecure.ms.talktalksa&hl=en_GB

 

Thanks

 

Debbie

ChrisFord
Enlightened One

@OCE_Debbie wrote:

Hi Chris

 

Apologies for the delay.

 

SuperSafe should work for all Android Devices running version 4.0 or up. So running on this HTC shouldn’t be a problem.

 

Just to confirm, are you installing the new SuperSafe boost? https://play.google.com/store/apps/details?id=com.fsecure.ms.talktalksa&hl=en_GB

 

Thanks

 

Debbie


Hi Debbie,

 

I was simply using the version that was offered from the "Play Store" at the time. However you must be a magician because I have just successfully installed the boost  from the same source with no problems at all. One of life's great unsolved mysteries I suppose!!

 

Many thanks for your help,

 

Chris

OCE_Debbie
Community Team - TT Staff

Hi Chris

 

That's great, thanks for keeping us updated 🙂

 

Debbie