NEED SOME HELP?

We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connected but no internet on certain devices

georgeb1971
Chatterbox
Message 3 of 3

HI, I have UFO and it's been working great for the last few months.  However today I've noticed that there are a couple of devices that connect to the hub but have no internet whereas other devices connect and work fine.

In particular my firestick all of a sudden has no internet - when checking settings it has connected to the hub but it says no internet.  Also my BT Youview box - this is connected via ethernet and says there is no internet and therefore no tv guide.  However my XBOX works fine as does my mobile that connects to wifi.  I read some similar posts on here that suggested the hub may be faulty??  Any ideas please

0 Likes
2 REPLIES 2

Michelle-TalkTalk
Support Team
Message 1 of 3

Hi george,

 

Have you tried powering down the router for a full 30 minutes and then retested this again?

 

Thanks

 

0 Likes

Atomic4l
Participant
Message 2 of 3

Hi George,

 

I am no way officiated with TalkTalk but ...

 

Are they getting an IP Address? If so have you tried manually adding another DNS in your network profile on your device? 

 

Try Googles Primary: 8.8.8.8 Secondary: 8.8.4.4 Or 1.1.1.1

 

If they don't get an IP Address try adding one manually to see if that gets you online.

 

I hope this helps.

Here to help, Eager to learn.
0 Likes