We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

UFO 1000mbs very poor speeds

UFO Customer
UFO Customer
Message 8 of 8

Just had UFO(york) broadband fitted this morning, the installation was on time, the guys where great and did a job above and beyond expected etc, and i'd buy any of them a beer even though I did discover one to have dubious music tastes in ''modern dj's''

however, the party was short lived because as soon as the connection was activated it proved to be awfully slow and slower than the VM cablemodem at 200mbs

running sppedtest i see speed of 100/120 as an average and had a few peak at like 180, not the sales guys over 900, or the welcomepacks letter stating in print that my postcode area should be 940mb..

nowcome on i am a realist, I dont expect full speed in the peak times of day and out of a quoted 940 if i say a 700+ i would be happy as i could be, but 150 average?

current speed...

EDIT: speeds improved and line tested ok at 750+ so not an equipment fault, but no real soloution yet discovered to original machines seems to be a router/nic issue, this will need to be confirmed by substitution of an identical nic to check for a 'troubled' nic or compat issue. (lez)




Message 1 of 8

Just a suggestion for you.


Not many servers can handle 940meg, I note from your screenshot you used a server in Sheffield, there are 3 servers in sheffield and only 1 of them can handle 940 meg and if that one is hammered it may affect the speed test.


Dont use the default recommended test links, try manually picking a test server.


Try the 2 below.


Manchester hosted by TNP LTD.

Hull hosted by Kingston Communications.


You need to hover your mouse over the city and pick the correct server.


They both can handle handle 1 gigabit and normally always show 900 for me.


Below, my test from Manchester-TNP LTD


Below, my test from Hull-Kingston Communications


 And just to compare, below result from the first listed server in Sheffield which I guess has a bottleneck with some old 10/100 hardware.


And below, results from the 2nd listed Sheffield server, which appears to have 10/100/1000 hardware, but has some other bottleneck.


Hope this is your issue?




Message 2 of 8


just had a visit from the original install guys, they tried the connection via wifi on their phones, 280+ etc, they tried their laptop, 120+, this caused some head scratching ... this is the speeds i was getting, faster often on wifi than wired, which is wrong, should never happen, and was the reason to look at the router as the fault

anyhow after a few reboots there laptop jumped upto speeds above 700, not something i have been lucky enough to see on my own machines with either dual core or quad core machines.

but I'm happy knowing the equipment is working fine and that my slower speeds (of faster machines than their laptop) must just be a compatability issue, needless to say as i have a wealth of equipment available to me for testing i will be trying other machines to try to find out whats causing this low speed.

if i find whats causing this 'should not happen' situation i will get back to you, at least by running 5 machines at the same time I am seeing the full speed shared over the 5, but just not full speed to a single machine thats a gigabit wired quadcore.


Message 3 of 8

Hi flez1966,


Could you please email me your following details directly on my email: . Both myself and my team will get in touch with tomorrow morning to sort the issue out for you.


1. Your account number / CLI number

2. Contact number and the best time you can be reached.


Kind Regards,



Message 4 of 8

hi, sorry i have looked in preferences above and cant find any way to enable private messaging.

anyhow the connection to the router is a direct cable from the pc (a q6600 quadcore machine with 8gb of ram and 14tb of hard drive space spread over 8 drives and a boot ssd) the net link was originally on auto(10/100/1000) but i have set it via device manager to 1000 full duplex only, so its at its fastest speed, the link state is showing connected so i guess the router can do this speed.

I have tried connecting via wifi and i do only see the 2g wifi option but i do not know if my computers wifi spec includes the 5g badwidth.

i will try this with another laptop etc to see if this makes a difference.



Message 5 of 8

Dear flez1966,


It looks your private messaging functionality is not enabled.


Could you please try sending me a private message with the below requested information:


1. You Account number / UFO CLI number

2. Contact number and the best time you can be reached.


Kind Regards,




UFO Customer
UFO Customer
Message 6 of 8

Hello flez1966,


We are extremely sorry to hear about the slow speed you are getting. I've sent a private message across to you to get more details from your side in order for our team to get in touch with you.


In the meantime, could you please let us know how you were connected when you had performed the speed test i.e. over wireless or wired conenction? If you over connected wireless, could you please confirm which frequency band of your wifi setup?


By default, our engineers should have setup two frequency bands on your router - 2.5GHz and 5GHz. If you only see one Wifi SSId appearig, it means the setup has not been done properly.


Please ping me the dtails and we'll sort it out for you.


Kind Regards,




Support Team
Message 7 of 8

Hi flez1966


I have given you access to the private UFO zone on the community and your post will be picked up by the dedicated support team in there.