cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Poor download speeds!!!

ANSWERED
Reply
8 REPLIES 8
Highlighted
First Timer

Hello,

 

Could anyone please suggest a way to fix the below? I have spoken to talktalk multiple times over the past couple of weeks about this who have assured me that fixes have been made to the hub to sort this out but still no change! Despite taking dates on two occasions for an engineer to visit still nothing has been booked, so I am hoping there might be a way I can sort this myself. Any help appreciated. Ben.

 

Annotation 2020-02-08 083937.png

 

Annotation 2020-02-08 082914.png

 

Annotation 2020-02-08 082730.png

 

Highlighted
Community Star

Can you try a wired test and see how that compares?

Highlighted
Conversation Starter

I think he is already doing a wired test Ferguson as he has got over 900mbps upload on one of the screen shots.   Only Wifi 6 would get anywhere near that.

Highlighted
Community Star

@peteb99 wrote:

I think he is already doing a wired test Ferguson as he has got over 900mbps upload on one of the screen shots.   Only Wifi 6 would get anywhere near that.


They look very much like screenshots from a mobile device to me, perhaps you could let the poster speak for himself?

Highlighted
First Timer
Solution
Hello,

Pete is correct, this is a wired test plugged in to router. I have tried plugging into the main white ufo hub but that makes little difference. I am often finding that I can get a faster dl speed over WiFi rather than internet which shouldn't be right. There's no issue with upload at all so really confused with this one.
Highlighted
Community Star

OK, this has been flagged up to the support team for you, you can expect a response when they are back online tomorrow.

Community Team

Hi Ben,

 

Have you tried speaking to the UFO support team?

Chris

Highlighted
First Timer

Hi

I am having the same issues as you at the moment. 

My wired connection shows a download speed of 95mbs,but when I use wireless I'm getting in excess of 350mbs.

 

Very strange behaviour as I thought a wired connection would show much better speeds.

When I had this installed the engineer plugged his laptop direct into the white box with the ethernet cable and showed me a speed of 1.2gb . I have since tried the same but still no difference 95mbs .

Don't understand what the problem is but hopefully get this fixed soon.

I know this doesn't help with your post/issues just thought I would share mine.

M Nettleton
Highlighted
UFO Customer

@Martin N 

 

Have a read up on 10/100/1000 NIC settings and capability.

 

As you are stating that you can only achieve 95, this falls inline with a NIC that can only achieve 10/100 at best (meaning no 1000 support).

 

Yes, wired should be faster, you need to provide details on the device you are trying that is connected directly, my guess is, it can only do (or set to) 100. Again, I am guessing an old PC or cheap laptop with only a 10/100 NIC.

 

Please post details of the device you are connecting directly!

 

Flagging things up to Talktalk response isn't going to magically fix your hardware restriction issue. So called senior talktalk support should know better!

 

Regards

Joey Boswell