cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

TV Support

For help with your TalkTalk TV box, channels and apps.

Forum Posts

PIN Number requests using TV HUB

If you have successfully signed into Apps such as ITVX and you are asked for a PIN number, this may be due to Parental Controls being set up during set up. The Box default PIN is 1234. Try this to access and unless you require Parental Controls to be...

fr8ys by Community Star
  • 173 Views
  • 0 replies
  • 0 like

ITVX and TalkTalk YouView boxes

For those wondering how to get ITVX on their boxes the short answer is you can't. This is the advice I have been giving other customers which may help. ITV updated the app and the software they use is no longer compatible with the YouView box hardwar...

fr8ys by Community Star
  • 11048 Views
  • 0 replies
  • 14 like

Now Tv - Offer Not Found

Joined Talk Talk with an activation date of the 1st of April. On this day my broadband went live and links were supplied for myself to activate my Now TV subscription. All links supplied have been dead returning an error message 'Offer Not Found'. Ti...

Marsh11 by Sightseer
  • 254 Views
  • 7 replies
  • 0 like

‘Offer not found’ for now tv

New customer went live on 9th April - linked Netflix okay, but getting nowhere with Now Tv. I’ve tried adding it myself, tried several emails sent to me after phoning helpline but all end up in an ‘offer not found’ page. Last person I spoke to said i...

Now tv issue

I signed up for a fibre broadband package with now tv cinema, sports and entertainment as well as netflix for £66 a month for 24 months. My broadband and netflix are working fine since the date my broadband was activated on 12th March. However my now...

Beths2 by Visitor
  • 171 Views
  • 3 replies
  • 0 like

Problem with tv remote

My remote isn’t working. I can’t change channels. When pressing home just get the apps. No tv guide

B4walks by First Timer
  • 139 Views
  • 1 replies
  • 0 like

Tv apps not

Tv apps not displaying have checked router and is fine

Rob25syc by First Timer
  • 133 Views
  • 1 replies
  • 0 like

Unable to play HD Bbc Iplayer anymore, error 02110

For the past 3 months I havent been abble to play HD content from my Talkttalk 4k tv box, the content is only 1080, it freezes and I get error 02110, new expensive Ethernet cable, so its either the box or the routter, speeds are stable at 64Mbps.

Loss of Live TV channels

My TV hub was installed on 04 Jan. 2024 and all was well untill 27th.Feb when Live T.V chanels not available but "Catch-up" OK. Message on screen says "week or no aerial signal coded YVM402. Where do we start to rectify please?

ERROR CODE

while attempting to use bbc iplayer the error code 01119 appears on screen, along with ‘Looks like something went wrong’ message? Turned hub off/on, plus same to tv a few times, same outcome

ym105

what is ym1o5  error message ?? 

joanna40 by First Timer
  • 115 Views
  • 2 replies
  • 0 like

TV Hub Set Up

Just setting up my TV hub and get the message on the TV 'video format not supported'. The screen alternates between blank, this message and an actual picture plus an occasional loud 'click'. The TV is a Philips 42PFL8404H/12. The box I am replacing (...

Error code YVM607

Trying to get Sky Sports News on my TV but it comes up with error code YVM607. What do I need to do. I’ve already switched everything off and on again but no difference.

JanCla by First Timer
  • 171 Views
  • 1 replies
  • 0 like

YVM102

We have had our Youview box many years but overnight we have got the YVM102 problem. Both Powerline adaptors are showing 3 green lights as normal. I have tried switching them off and rebooting the box several times but this hasn't helped. The etherne...

DN360T / DN370T / DN372T Software update no longer working

Hi, I recently replaced my DN370T box (after it packed up) with a DN372T, but noticed the software wasn't up to date. When attempting to update the software, I get a message saying "Sorry, an error occurred while trying to update your software. Pleas...

xyberlink by Popular Poster
  • 3441 Views
  • 21 replies
  • 1 like

TV Box Reboot Loop

My box is in a maintenance mode reset loop where it keeps failing to start after issues with playing recorded videos started happening forcing me to reset.