Reply
New Contributor
luuts
Posts: 2
Registered: ‎02-08-2013

D-Link DSL-3680 in "modem only" mode connected to Asus router

[ Edited ]

I have a TalkTalk provided D-Link DSL-3680, and I'd like to hook up my own router (Asus RT-N66U) to it. 

My current setup is to have the Asus router using a static IP while connected through it's WAN port to the DLink modem. The DLink modem has it's DHCP server and firewall disabled in order to try and not be "like a router". But this means I'm in a double NAT situation with a local IP on the router.

 

What I'd ideally like is for my router to have the WAN IP of my modem, and for the DLink to act as a dumb modem to pass all traffic through to the router. I tried with the DLink's "bridge mode", but because TalkTalk uses PPPOA and not PPPOE my router isn't able to connect to the internet.

 

If anyone has any tips to disable NAT on the DLink, or any other way I can setup my network it would be greatly appreciated!

Thanks.

Occasional Contributor
akarpun
Posts: 12
Registered: ‎02-08-2013

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

Well, You should have serious reason to setup a such configuration as most of SOHO routers (especially from different manufacturers) will not work well together. 

Anyway - You was right about setting one of routers into bridge mode, although I didn't understand from Your message what configuration You trying to make and why.

In my case (I got D-Link DSL-3680 and Airport Extreme) I turned off wireless on D-link (it acting like modem/wired router) and set Airport into bridge mode (it provide internet via wireless connection to all computers in house).

Please note: I didn't touch any other settings (DHCP, NATs - anything) as bridge mode sorted it all, and everything working just fine.

I made this setup because D-Link DSL-3680 is have bad wireless connectivity due some malfunctioning.

New Contributor
luuts
Posts: 2
Registered: ‎02-08-2013

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

Yeah, really sorry about this. I actually figured it out just after posting.

 

FYI to anyone else trying a similar configuration, the bridging does infact work through the DLink to another router, and said router can indeed connect via PPPOE to the router, just make sure your static IP is correct and valid to your modem.

 

akarpun, I'll mark your response as solution anyway, just for being nice and responding. Ta!

Occasional Contributor
benedictwarner
Posts: 7
Registered: ‎03-08-2013

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

We've been having some problems with our DSL-3680 router supplied by TalkTalk, and while I've found some other suggestions as to how to solve the problems elsewhere on the forums, one option I was considering was exactly as you've described - turning off the 'wireless' mode on the DSL-3680, and connecting it to my Airport Express to act as a router.

 

However, I'm not sure if I can do this with an Airport Express (as opposed to an Airport Extreme). On the Apple Forums, someone else has asked (here) if Airport Express can be used in bridge mode from a non-Apple router, but the support article linked in the 'solution' (here) seems to suggest that the Airport Express will be in client mode and as such 'other devices, such as computers, cannot connect to it wirelessly'.

 

Is this right? If I use an ethernet cable to link our DSL-3680 router to my Airport Express and turn off 'Wireless' in the D-Link router's settings, will that create a useable WiFi network in our flat?

~ MacBook (White, 13", 2007), 2Ghz Intel Core 2 Duo, 2GB RAM, 320GB HD, Mac OS X (10.6.8) & Ubuntu 12.04 ~ iPhone 4S 32GB, iOS 6.1.3
Occasional Contributor
akarpun
Posts: 12
Registered: ‎02-08-2013

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

To: Benedict Warner

I didn't have a chance to play with express but Google searches result indicate express can be used in bridge mode. What You should do is link your express via cable to dlink and switch it in Air utility to bridge mode.
Try and if it's works than turn of wireless of on your Dlink.
I found this guide - maybe it will be useful: https://sonos.custhelp.com/app/answers/detail/a_id/1100/~/how-to-properly-setup-an-airport-express-a...
Only one thing: connection between routers should be via cable to guarantee stable work and overcome faulty Dlink wireless.

Good luck
Contributor
BillyBlaze
Posts: 60
Registered: ‎30-04-2012

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

Similiar setup; here goes:

 

Dlink 2680 supplied from talktalk:

 

Set LAN IP to 192.168.1.1, then > Setup, ADSL Setup, chose bridge mode, 1483 bridged IP VC-MUX, save/reboot

 

Linksys E3200:

 

Set LAN IP to 192.168.0.1, then > WAN/Internet, chose PPPoE, input talktalk username and password, mtu 1392, DNS 8.8.8.8, Wireless settings etc.

 

**Also note I had to leave DHCP on the Dlink, i think this was so i could still access the web interface or something**

 

Good luck

 

Occasional Visitor
dsc_1966
Posts: 1
Registered: ‎08-09-2013

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

As I have multiple wireless devices providing a WDS (a repeating wireless network) network around my house / garden I wanted to ignore the Talk-Talk router and set my apple gear as primary router.

 

  1. Connect your computer to the Talk Talk wireless network using your web browser.
    This is done by: http://192.168.1.1
  2. When prompted to  log in to the router
    username: admin
    password: admin
  3. Goto the “Advanced” option.
    The only change to make is: Change selection from PPPoE/PPPoA to BridgeMode
  4. Save Settings.
  5. Disconnect from talk talk wireless network and switch to your wireless Apple Network.
  6. Run Airport Utility and connect to your Apple Wireless Router.
  7. On the Internet Tab, change Connect Using to: PPPoE
  8. Account Name: 0123456789@talktalk.net (your talk talk account details)
  9. Password: your talk talk password.
  10. Select the Internet Options... button
  11. Change to PPPoE Connection: Automatic
  12. Save.
  13. Wire your Apple Router using an Ethernet Cable from the WAN port to LAN 1 on the talk talk router.
  14. Reboot both routers.
  15. Connect to your Apple Network.
  16. You should now have your apple router(s) providing your home wireless network.
  17. Optional: Press the WLAN button on the side of the talk talk router disable the talk talk wireless network. You can always enable it again if for any reason you need to connect to the talk talk router to reconfigure via http://192.168.1.1

 

Community Star
jcampy
Posts: 11,621
Registered: ‎18-02-2010

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

I wouldn't reccomend wds as it limits it to 54mb and wep security


Don't forget to add your phone number to your forum profile


New Contributor
balazs
Posts: 4
Registered: ‎06-02-2014

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

Hi luuts,

 

I have the same problem and couldn't solve it yet. What do you mean on "make sure your static IP is correct and valid to your modem"? I only have PPPoE on my router available and don't know if that's why it's unable to connect...

 

Thanks,

Balazs

Occasional Visitor
Corbain
Posts: 1
Registered: ‎02-11-2014

Re: D-Link DSL-3680 in "modem only" mode connected to Asus router

[ Edited ]

dsc_1966,

 

THANKS!!!!!

 

This was exactly what I've spent the last month banging my head against the wall to discover.  I litterally just changed my router to Bridged Mode and added the login information to my second router.  Now my DDNS and AiCloud and everything works.