cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Router turned off now will only load https websites

Reply
6 REPLIES 6
Highlighted
First Timer

Hi, I have been on fibre for several months. I have the D Link DSL 3782. Earlier it got knocked over and power went off. After turning back on, it will load websites with https, if it's HTTP I get a sign in box with the message 'your connection to this site is not private'. If I press cancel , it displays the following '401 unauthorized Your client does not have permission to get URL/cgi-bin/index.asp from this server' or '400 bad request your client has issued a malformed or illegal request' any advice please?

Highlighted
Community Star

This is most likely down to security enhancements in your web browser. Chrome for instance has been getting stricter on this for some time, with the latest version about a week back, going even further. 401 is an authentication error.

 

If there was anything wrong with the broadband or router, you wouldn't be able to get to the HTTPS sites.

Highlighted
First Timer

I've been getting the same issue on my laptop and PC when connected to my TalkTalk router, either by LAN or Wireless.  If I connect to another network, such as using my phone as a hot spot or my company network, it all works fine.

 

So seems TalkTalk related to me...

Highlighted
Conversation Starter

Can you try a desktop or laptop connected via ethernet to the router (and for the test disble the wifi on the desktop / laptop).

 

that error can occur if wi-fi credentials are off.  If you connect ethernet and it all works, then resync / check password .. etc both ways.

.. That as well as if 2.4 and 5Ghz are both on on your router. (check wireless ID's .. etc).

 

It'll explain the able to connect to otherwireless networks and it all be fine . Likely the wifi, whilst may seem like it connects / syncs .. actually doesn't

Highlighted
First Timer

Hello,  Tried that I'm afraid LAN with Wireless disabled and I still get the same issue.

Highlighted
Conversation Starter

Thanks for the test, the other thing could be saved passwords in the browser . But that one's usually covers those that need credentials (and loads of people click save password).

 

Then there's the custom levels security in some browsers.  But sounds like all works on other wireless networks.

 

 Then there's setting in the router (http over https . s over http (whichever it is)), but better for maybe OCE to jump on your router and check those settings.

... Bar you possibly doing a fact reset on it, but possibly await OCE before that.

 

The only other thing I can think about is DNS, DDNS, home DNS .. that the hoster has lost credentials. so when passed from fqdn to ip, the credentials aren't passed from the host.

Highlighted
Community Star

Like I said earlier it is most likely down to security enhancements in your browser, if you can get to https sites, that proves your broadband OK. The issue of 2.4 or 5GHz Wi-Fi bands, passwords, DDNS (why - that only affect incoming connections?), would not stop you getting to http sites - in fact you should not even be using passwords on an http site as they are unencrypted. Then there is the issue of http over https, I don't think there is such a facility.

 

What browser on what type of device & operating system are you using?