cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Talktalk Router not working

Reply
14 REPLIES
luke_hobster
Chatterbox

I recently received a router from TalkTalk, at first it would switch on fine and I could connect to set it up, but now when I plug it I only get 2 lights, Power & Internet, both of which are red, no Wifi network shows up for me to connect to, and it also doesn't work with an ethernet cable. Everything is plugged in the same and the cables work with an older router. The Talktalk router will also sometimes look like it is resetting itself by the lights changing for a few seconds. When switching it on the ADSL light flicks on for a second then dissappears.

 

It is a huawei hg533.

 

I have tried the reset button and the Wlan button but it is still the same.

 

This is what the router looks like: 

 

jasonr2013
Insightful One

hi it looks like the router has bricked somehow

 

during a software update

 

your best bet is to get an OCE to request a replacement router for you

 

as there is no way around this as talktalk dont supply the Firmware to recover the router

 

 

luke_hobster
Chatterbox

Hi, thanks for your reply. May I ask what an OCE is?

jasonr2013
Insightful One
Sure an OCE is the ones who we contact on here for help they are quicker than ringing talktalk themselves and speak proper english
luke_hobster
Chatterbox

Ohh I see, how would i arrange a replacement with those? Appreciate the help!

jasonr2013
Insightful One

your most welcome with the help

 

an OCE will see this and be able to assist then just make sure your profile contains your landline number

 

so they can assist much quicker

 

so bare with them and they will get to you shortly

 

 

luke_hobster
Chatterbox

Thanks!

TalkTalk Team

Hi luke_hobster

 

Thanks for your post,  Welcome to the community. 

 

It does seem that the new router has died on you,  I will request a replacement and a returns bag for the faulty one. 

 

Allow 3-5 days for delivery. 

 

Regards 

luke_hobster
Chatterbox

Thank you!

TalkTalk Team

Hi luke_hobster,

 

Let us know how you get on Smiley Happy

 

luke_hobster
Chatterbox

New router received today, all set up and working! Thanks

jasonr2013
Insightful One

glad its all sorted for you Smiley Happy

TalkTalk Team

Hi luke_hobster,

 

Thanks for keeping us updated Smiley Happy

 

luke_hobster
Chatterbox

Using it for the past couple of hours has been painfully slow, I have had to put the old router back in (old router works so definitely no ISP problem). Any ideas of why it could be going so slow?

 

There are multiple devices connected to it at the same time around the house - laptop, 2 phones, 2 ipads, sometimes another 2 laptops...

OCE_Mark
Retired

Hi Luke,

 

Can you run a check on the Service Centre with the new router in place and follow the report and repair steps.

 

Cheers


Smiley Happy