cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Sky Sports picture quality

Reply
11 REPLIES
Patrick17
Team Player

I’ve put Sky Sports on today and noticed that the picture quality is significantly worse than compared to some of my old recordings from the same channels.

 

They’re all looking of a similar quality to the Sky Cinema channels (which are normally noticeably poorer).

 

Not sure it’s a coincidence that I had multiroom installed yesterday. But when it was first installed the PQ was great as I remember thinking how good it looked on my second TV. However it's now noticeably worse on both TVs with lots of pixellation and ocasional blocks in picture appearing.

 

I’ve restarted both boxes and the router (speeds are good ~35mbps), rebooted homeplugs etc.

 

Needless to say I’ll be disappointed if this is a side effect of adding multiroom as this wasn’t mentioned.

 

Only other recent change has been the installation of the new wi-fi hub, and I've cancelled the Cinema boost (and by extension lost the legacy Starter pack. As an aside I wasn't expecting to lose these until this billing month was up but they've gone already).

HollyBy
TalkTalk Products Team
Hi @Patrick17

This doesn't seem right based on your speeds. Could you let me know how each box is connected (ethernet or powerline adaptors) and which powerline adaptors you have?

Thanks, Holly
Patrick17
Team Player

@HollyBy wrote:
Hi @Patrick17

This doesn't seem right based on your speeds. Could you let me know how each box is connected (ethernet or powerline adaptors) and which powerline adaptors you have?

Thanks, Holly

Hi Holly

 

It’s looking loads better today. I haven’t made any changes to my set up so looks like it might have sorted itself out. Will post again if issue returns. Thanks

HollyBy
TalkTalk Products Team
That's great Patrick. I actually just found out that there was some maintenance work on Tuesday which would have caused this, so glad you can see the difference now that it's finished.

Thanks, Holly
Patrick17
Team Player

@HollyBy wrote:
That's great Patrick. I actually just found out that there was some maintenance work on Tuesday which would have caused this, so glad you can see the difference now that it's finished.

Thanks, Holly

Glad to hear I wasn’t seeing things! Thanks for the update

Patrick17
Team Player

Just wondering if there is some maintenance work taking place today, as above? Picture’s not great on any of the Sky Sports channels, similar to what I was seeing when I created this thread.

fastfurious65
First Timer

Yes I got the same problem.

 

The aspect ratio doesn't look right. The scoreboard and channel logo are much closer to the edge of the screen that it should be.

 

The picture quality looks worse than usual.

 

And tonight, Sky Sports Premier League doesn't seem to be working for me. Was working earlier this afternoon.

ghfghf
Patrick17
Team Player

Picture still poor today. Ran a search on Twitter and saw numerous people reporting the same thing.

Can you shed any light? 

@HollyBy

@OCE_Karl

HollyBy
TalkTalk Products Team
Hi @Patrick17

I've not been notified of anything, but I'm checking with our technical teams to see what they say. I'll let you know when I have an answer.

Thanks, Holly
HollyBy
TalkTalk Products Team
Hi @Patrick17

Unfortunately it seems there was an outage on Saturday night which caused this and for some reason it hadn't been flagged to us correctly. Thanks for raising it, it should now be resolved.

Thanks, Holly
fre55die
Community Star

Hi @fastfurious65

 

Could you please start your own thread for support as each problem is individual and needs investigating separately.

Could you please also ensure that your community profile includes your PHONE NUMBER as OCE's will need this to tie up your screen name to your account. (click on your avatar to view the information > Settings > Launch Profile Wizard,put your phone number in box, then scroll to the bottom of page and click save)

If this has helped and solved your problem, please mark it as Best Answer so that OCE's or others do not spend time looking for alternatives.
Patrick17
Team Player

@HollyBy wrote:
Hi @Patrick17

Unfortunately it seems there was an outage on Saturday night which caused this and for some reason it hadn't been flagged to us correctly. Thanks for raising it, it should now be resolved.

Thanks, Holly

Thanks Holly.

 

All back to normal here.