cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

email support

Ask us about your TalkTalk email account and Webmail.

Is Tiscali email server down again?

Keith90
First Timer
Private Message TalkTalk
Message 61 of 61

Tiscali email not able to receive or send messages on my MacBook, but mail is visible on my webmail.

 

Keith
60 REPLIES 60

Artistef
Chat Champion
Private Message TalkTalk
Message 21 of 61

Problem solved, for me at least. I was using smtp.dsl.pipex.com. Changed it to smtp.talktalk.net. I seem to recall having a problem with smtp.talktalk.net when Talktalk updated the servers. A notification would have been nice.

MarcusS
First Timer
Private Message TalkTalk
Message 22 of 61

I set it up from scratch, but I didn't close and re-open Outlook.

 

I've done that now and my emails are gradually arriving, but of course its downloading the entire content of my mailbox.

 

This has caused me, and many many others users a lot of time, stress and trouble, and all because TalkTalk appear to have made a significant change without bothering to alert its CUSTOMERS. How are we supposed to know that the settings we have been using for many years are out of date?

 

Making these changes is at the very limit of my skills and I doubt older customers would be able to do it. I'm sure other providers would not do this to their customers.

Message 23 of 61

Hi MarcusS, did you remove the email account and set it up again from scratch or did you change the settings in the existing account in Outlook? If the latter please do the former and close Outlook after removing the old and again after adding the new one.

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


MarcusS
First Timer
Private Message TalkTalk
Message 24 of 61

Just spent ages deleting and re-setting up my Tiscali email account in Outlook using the settings that were posted by TalkTalk yesterday, but I still can't get a connection. These are the setting I used.....

 

POP3 incoming server for ALL TalkTalk Mail domains

mail.talktalk.net using SSL/TLS connection security on the secure POP3 port 995

 

SMTP outgoing server for ALL TalkTalk Mail domains

smtp.talktalk.net using StartTLS connection security on port 587

 

Web mail continues to work fine.

 

PLEASE PLEASE can somebody at TALKTALK sort this out and PLEASE PLEASE tell us when it will be fixed.

0 Likes

Message 25 of 61

The error code you posted suggests you're trying to use an outdated email client like Outlook 2007 or Outlook 2010. If that's the case then please cease using as there's a security risk for you and the TalkTalk network users. The recommended secure mail settings are given below but deprecated / outdated and insecure email clients will not be able to use these.

 

The email client software / app may require updating of email settings. All TalkTalk Consumer mailboxes use the same Email Settings. See  TalkTalk Mail Support Hub

 

On updating the email software incoming, outgoing and some advanced server settings, you'll possibly be asked to accept a new certificate (yes, accept) and to enter the email password so have the current password ready. Tick to remember or save the password before entering it.

 

Supported* email client and app settings are:

Account Type  IMAP (recommended) or POP3
Username Full email address
Password Email password
Incoming mail server mail.talktalk.net
Incoming Port (IMAP / POP3) 993 / 995
Incoming Connection Security SSL/TLS (Use SSL on for mobile)
Outgoing mail server smtp.talktalk.net
Outgoing Port 587
Outgoing Connection Security STARTTLS (Use SSL on for mobile)
Outgoing Authentication Required Yes
Authentication Method Normal Password

Apple/Mac Mail Connection Security is use TLS/SSL

 

It's also important to make sure the email address is added to a TalkTalk Consumer customer MyAccount to avoid restriction to webmail only access and possible deletion. 

 

 Email not showing in My Account

 TalkTalk Mail Plus is the mail only subscription service for TalkTalk Mail users in the UK that are not home broadband customers.

 

* Email clients, apps and devices that do not support secure mail using a minimum of TLS1.2 connection security are not supported.
TalkTalk may also choose to disable POP3 connectivity which is why IMAP email is recommended.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

lynnpash
Participant
Private Message TalkTalk
Message 26 of 61

 I still have no tiscali.co.uk emails in or out.

So please can someone help me. This is clearly TT as I have chnaged nothing. It would help to have a resolution on this.

Message 27 of 61

Ken, you posted the same post twice in two different places. We call that spamming the forum.

 

By now you hopefully know that by not keeping up to date with TalkTalk's Help content on the TalkTalk Mail Hub you've not updated the legacy tiscali settings to the talktalk settings that have been recommended since 2018.  The legacy settings have still worked because TalkTalk has not totally withdrawn them...yet.

 

Just in case you didn't read back on this topic you hijacked here are the settings you need for your POP3 TalkTalk Mail account.

 

POP3 incoming server for ALL TalkTalk Mail domains

mail.talktalk.net using SSL/TLS connection security on the secure POP3 port 995

 

SMTP outgoing server for ALL TalkTalk Mail domains

smtp.talktalk.net using StartTLS connection security on port 587

 

Authentication is with the Full email address as Username and normal email password

 

 

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

Message 28 of 61

My outgoing server name appears to be smtp.tiscali.co.uk

0 Likes

AnnHow1
Chatterbox
Private Message TalkTalk
Message 29 of 61

Ok. So I was using smtp.tiscali.co.uk for outgoing mail. I think there was a reason for this as smtp.talktalk.net is actually in my list of alternative servers but it appears it wasn’t working for me. Anyway I’ve changed the server back to smtp.talktalk.net again and this now works.

0 Likes

Message 30 of 61

Didn't realise I was spamming anything.  My e-mail has been down all day and I'm just trying to find some help getting it sorted.

 

As stated in my earlier post, I am using Thunderbird as my e-mail client.

 

Looking at the Account Settings in Thunderbird, the Server Name is set to pop.tiscali.co.uk, with a Port Number of 995.  I have no idea if that is a legacy server host name.  I set it up, in accordance with TalkTalk documentation, some years ago and I've not been made aware of any need to change it, since then.

0 Likes

James_Sunderland
First Timer
Private Message TalkTalk
Message 31 of 61

Same for me; no outgoing or incoming tiscali emails in Mail on Win 10 (but my GMail works fine).

 

Definitely an issue on Talk Talk's end.

0 Likes

Message 32 of 61

You're good at spamming the forums Ken. What email client are you using and what server host names? If you haven't made any changes for a long time then does that mean you're using the legacy server host names?

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

0 Likes

kenpragnell
Team Player
Private Message TalkTalk
Message 33 of 61

I have not made any changes to my account settings for a long time. I've checked the port numbers and they are as suggested below.

 

Nevertheless, I have been unable to send/receive any e-mails via Thunderbird all day. I can still access them via WebMail.

 

Thunderbird was happily accessing my tiscali.co.uk e-mails late yesterday evening.

 

I hope your engineers are still working on the problem, as it has not been solved for me.

0 Likes

Message 34 of 61

Pretty sure I have tried the correct settings in the past but for some reason pop 3 Tiscali emails didn't like, which is why I was stuck with the old settings. 

Still at least the "correct" settings now appear to work so all is well. Looks like I wasn't the only one to be caught out!


Message 35 of 61

Hello @Attax991 

 

Welcome to using the correct TalkTalk Mail settings.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

0 Likes

Message 36 of 61

Funnily Gondola reported this on a separate thread a little while ago. 

https://community.talktalk.co.uk/t5/Email/Difference-between-IMAP-and-POP-server/m-p/3041275#M179703

 

so for POP accounts 

POP3 incoming server for ALL TalkTalk Mail domains

mail.talktalk.net using SSL/TLS connection security on the secure POP3 port 995

 

SMTP outgoing server for ALL TalkTalk Mail domains

smtp.talktalk.net using StartTLS connection security on port 587

0 Likes

Message 37 of 61

@Attax991 Thanks for confirming. Our engineers are still looking in to this issue.

0 Likes

Message 38 of 61

Reset and still old Tiscali POP account settings wouldn't work for pop.tiscali.co.uk port 110 (for incoming),

smtp.tiscali.co.uk port 587 (outgoing).

So had a play with different settings, using my Tiscali email. 

Found the following seems to work for me!


mail.talktalk.net port 995 incoming (SSL/TLS required),

and smtp.talktalk.net port 587 outgoing (STARTTLS encryption and outgoing smtp requires authentication).

 

No idea why old pop settings suddenly stopped working, so will stick with the above until it breaks again....

lynnpash
Participant
Private Message TalkTalk
Message 40 of 61

This is very poor. No email using my tiscali email on outlook since early this morning.

Several hours before anyone picked this up and now 5 hours since then and still no resolution. Clearly a Talk Talk issue. Probably a change made overnight.

0 Likes