cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Weak Wi-Fi Security following iOS 14 update

Community
Security
Technology
Community Team - TT Staff

If you’ve recently updated your Apple device to iOS 14, you may have noticed a new message warning of ‘Weak Security’ on your Wi-Fi connection. This will have happened following the recent iOS 14.01 update Apple have released on some devices. When any device tries to connect to your router, it will always use the highest security settings available on both the router and the device. So there is no need to worry, your Wi-Fi connection is still secure.

With the help from one of our Community Stars KeithFrench, we’ve put together some information to help you update your router settings and remove the ‘Weak Security’ message.  

By default all TalkTalk routers allow WPA2 Personal and the older WPA2-TKIP to be in the list of available security modes. This means that whilst your iPhone is connected using WPA2 Personal (safest, most secure wireless protection), an older device that only supports WPA2-TKIP, can also connect via Wi-Fi but with the poorer security mode.

Your updated iPhone is prompting you to remove the less secure mode from your TalkTalk router. Although this won’t affect the Wi-Fi connection with your iPhone, making this change could mean older devices may no longer connect.

If you want to restrict the available security modes available in your router and remove the Apple warning message, please follow these simple steps:

  1. Open your browser and type in 192.168.1.1 (default address, modify if changed)
  2. Login by entering the Username: admin and Password: On the label on the back of your router

You'll need to change:

Wi-Fi Security mode to: WPA2-PSK only

Encryption to: AES

This can be found at the location below for the following TalkTalk routers:

 

Huawei HG633/635

Home Network > Wireless Settings > Encryption

 

Huawei DG8041W (called WPA2 PreSharedKey on this router)

Dashboard > See Internet Settings > Manage advanced settings > Advanced Configuration > WLAN > 2.4G Basic Network Settings

Dashboard > See Internet Settings > Manage advanced settings > Advanced Configuration > WLAN > 5G Basic Network Settings

 

Sagemcom FAST5364 (Set Security to WPA2 Personal, this must also set the encryption to AES as no separate option for this)

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 2.4Ghz gear icon > Basic

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 5Ghz gear icon > Basic

 

DSL-3782

Settings > Wireless (Wi-Fi)

In the Security Settings set:

Security: WPA2

WPA2 Type: PSK Value

Then go to Advanced settings & under the “Share Security” advanced settings, ensure that the “Cypher Type” is set to “AES”.

 

You should now find the Apple message 'Weak Security' is no longer displayed.

 

About Mikem

Hi, I look after all of the Mobile & TV content on Help & Support. I love Photography, technology and family time.

Check out more blogs from Mikem