Showing results for 
Show  only  | Search instead for 
Did you mean: 


We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

Newest Talktalk router won't cast video to Smart TV

Private Message
Message 5 of 5

I recently received the newest TalkTalk router (TalkTalk Wi-Fi Hub) and now I can't cast videos from my Windows 10 laptop to my Samsung Smart TV. The previous TalkTalk router (HUAWEI HG633) cast videos with no problems at all. In fact I unplugged the new router (leaving all the broadband gubbins connected) and plugged in the old router as just a wireless network (no Internet) and I could cast videos just like I used to.

With the new router the TV shows up under "Cast to Device", but when I click on it Cast to Device thinks about it for a while then displays "Media is not available". I assume there is something different in the settings of the new router that is stopping the video from streaming, but I can't figure out what it is.

Just to be clear: I don't want to mirror my laptop screen on the TV, just stream videos to it.

Thanks for any help.


Message 1 of 5

I'm not at home at the moment so can't check the firmware, but the firewall is set to medium. I temporarily set it to low to see if it made a difference, it did not.


Message 2 of 5

Is your Wi-Fi Hub on the latest firmware version SG4K100158?


Under no circumstances turn the firewall off. The Advance Settings Access control firewall setting should be Medium. If not on the latest firmware and the Hub has inadvertently been defaulted to a High setting then reset to Medium.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution


Message 3 of 5

Thanks for the response. The Sagemcom Wi-Fi Hub has exactly the same SSID and password as HG633. I have forced both the TV and laptop to connect to the 2.4ghz band, still doesn't work.

I want to stream video content stored on my laptop to the TV not online videos.

All my devices connect to the Wi-Fi without any problems, but I have discovered an additional problem: I can't access any of my shared drives from my laptop over the Wi-Fi network with my other laptop or android phone. This also worked perfectly with the old HG633.

I'm starting to think it might have something to do with the firewall on the Sagemcom Wi-Fi Hub? But I don't know how to get round it/turn it off.


Community Star
Private Message TalkTalk
Message 4 of 5

Connecting your device and TV to the same Wi-Fi network is a key requirement for casting things like YouTube videos.


Your TV is obviously recognising the Wi-Fi network name of the HG633 router. Have you set up the Sagemcom Wi-Fi Hub to use the identical Wi-Fi network name that you had on the HG633 and made sure the device is connecting to the same Wi-Fi network.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution