Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unifi Dream Machine

JamesJones01
First Timer
Message 3 of 3

Good morning,

Yesterday I tried to set up my Unifi Dream Machine. I have an ECI modem for this purpose and have read the USG tutorial which explains that you must first configure the USG on the network after disabling DHCP on the router.

 

I tried this and lost all my router settings (sagemcom), needed to factory reset it, and still couldn't connect the UDM. Unfortunately the UDM won't configure when plugged into the LAN port as opposed to the WAN port, unlike the USG, so I cannot get it adopted to the network. 

 

I have signal coming through the ECI and can visit web pages using a pc and ethernet direct to ECI. But, not with the UDM, which is unable to speed test or log in to my Unifi account.

 

I have forced it to go to advanced network options and tried all the settings for PPPOE, which I believe I am on, and for DHCP just in case. I have tried various combinations of the above, using the info copied from the router and the info from the help page. Unfortunately both of these routes lead to no internet connection, which the UDM is not claiming when it fails to run the speed test.

 

So far this forum has been a great help, however I'm at a slight stumbling block here.

 

Any ideas?

0 Likes
2 REPLIES 2

JamesJones01
First Timer
Message 1 of 3

Solved this. Apparently the old firmware is no longer compatible. Some people have got some this by setting up the UDM on a network with DHCP temporarily disallowed, then upgrading the firmware before migrating out

 

. Unfortunately this did not work for me.

 

 

 

Unifi have a process for flashing the firmware via the Eth 1 port on the UDM during a recovery boot.

 

1. Download latest firmware to an Ethernet capable device and set is static ethernet IP to 192.168.1.11

 

2. Shut down UDM remove power.

 

3. Plug back in and hold the reset button (on the bottom) for 5 seconds. LEDs should flash 2x white then 2x blue. This indicates recover mode.

 

4. Connect the eth1 port to your pc with the static IP address and go to 192.168.1.30

 

5. Use the firmware upload tool to upload the file. Once installed it will reboot.

 

 

 

This should work fine.

 

Talk talk connection + ECI modem + UDM. No PPPOE config, no changes to default config for DHCP connection. No change to my speed, but now the capability to add vlans,

 

 better iot security and other cool stuff. 

 

 

0 Likes

KeithFrench
Community Star
Message 2 of 3

Without having such equipment myself, all I can do is suggest that you contact the manufacturers support team.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes