Showing results for 
Show  only  | Search instead for 
Did you mean: 

email support

Ask us about your TalkTalk email account and Webmail.

Is Tiscali email server down again?

First Timer
Private Message TalkTalk
Message 61 of 61

Tiscali email not able to receive or send messages on my MacBook, but mail is visible on my webmail.



Private Message TalkTalk
Message 1 of 61

Thanks Ken and James.

It was totally out of order.

Its quite clear it was a TT issue. Whilst we all know IT has upgrades and changes that are required at times. Changing things, such as settings etc, not everyone can or has the confidence to make changes. I think someone actually someone made a comment about this.

I was also dismayed that he accussed Ken as spamming. Ridculous. TT customers come here as TT support frankly is not good enough. Long waits and constant going over the same thing so you stay on the phone for longer, drives me mad. If advisors on here cannot act in a friendly, professional manner, maybe they should stop doing it.  I appreciate help and always give a like, but no like from me this time.

It costs nothing to be kind, when all customers want is to have their problems solved.


First Timer
Private Message TalkTalk
Message 2 of 61

I agree with both of you guys; his attitude was not at all warranted, and I found it a distraction when trying to find a solution to this issue.


Also, it's worth pointing out that he is not a Talk Talk Staff member.


Message 3 of 61

I absolutely agree with lynnpash.  I was also irritated by the suggestion that I had committed the heinous crime of spamming, where all I done was make a small mistake and then tried to correct it. 


I strongly suggest that Gondola gets some training in dealing with customers or else considers an alternative career - prison warder maybe!

Private Message TalkTalk
Message 4 of 61


Please don't speak to me like I am an idiot. 'DO YOU UNDERSTAND' is not the way to speak to a customer of many years. I asked you a polite question and received your aggresive message by return. Customers do not like being threatened, they can walk away and choose another supplier.

I am on Microsoft 365, I don't use old outlook connections. I already had posted this but no-one responded to me. I asked whether I should change my settings and all you needed to say is Yes please use these settings from now on.

No notifiction has ever been sent out by TT saying everyone on other client email address's, such as Tiscali, Pipex etc should change their settings. If this was necessary for security reasons , it should have be explained. Then everyone could have made the changes as required and none of us would have had to wasted an enormass amount of time on this subject.

Considering the Chaos caused this week due to talktalk and no-one else, TT should be apologising to its customers. We are all paying for a service and should be treated with respect.


Message 5 of 61

DO NOT USE PORT 110 - That is an insecure port and continued use will result in TalkTalk barring you from using anything other than webmail. DO YOU UNDERSTAND?  The error code you posted previously suggests you're trying to use an outdated email client like Outlook 2007 or Outlook 2010. If that's the case then please cease using as there's a security risk for you and the TalkTalk network users. The recommended secure mail settings are given below but deprecated / outdated and insecure email clients will not be able to use these.


For POP3 secure mail incoming use the server host name ONLY. Port 995 and connection security SSL/TLS.


DO NOT USE SMPT.TALKTALK.NET - That is a typographical error and will never work.

For SMTP secure mail outgoing use the server host name ONLY. Port 587 and connection security StartTLS.


The email client software / app may require updating of email settings. All TalkTalk Consumer mailboxes use the same Email Settings. See  TalkTalk Mail Support Hub


On updating the email software incoming, outgoing and some advanced server settings, you'll possibly be asked to accept a new certificate (yes, accept) and to enter the email password so have the current password ready. Tick to remember or save the password before entering it.


Supported* email client and app settings are:

Account Type  IMAP (recommended) or POP3
Username Full email address
Password Email password
Incoming mail server
Incoming Port (IMAP / POP3) 993 / 995
Incoming Connection Security SSL/TLS (Use SSL on for mobile)
Outgoing mail server
Outgoing Port 587
Outgoing Connection Security STARTTLS (Use SSL on for mobile)
Outgoing Authentication Required Yes
Authentication Method Normal Password

Apple/Mac Mail Connection Security is use TLS/SSL


It's also important to make sure the email address is added to a TalkTalk Consumer customer MyAccount to avoid restriction to webmail only access and possible deletion. 


 Email not showing in My Account

 TalkTalk Mail Plus is the mail only subscription service for TalkTalk Mail users in the UK that are not home broadband customers.


* Email clients, apps and devices that do not support secure mail using a minimum of TLS1.2 connection security are not supported.
TalkTalk may also choose to disable POP3 connectivity which is why IMAP email is recommended.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution


Private Message TalkTalk
Message 6 of 61

Although all my emails are getting through to my Pop3 account using the old 110 incoming and 587 outgoing old settings on my laptop , it will not work on my Amazon fire 10, when it was working fine.

I really don't understand what is going on.

Should I change Pop3 to using and on both?

I'd still like to understand what has happened.


Message 7 of 61

Same here. What a relief. But this should never happen.  A few years ago it was a regular occurrence but I thought all was good now. Anyway, good to have it back.


First Timer
Private Message TalkTalk
Message 8 of 61

Just an update: I logged on a few minutes ago and all my tiscali emails from the last couple of days arrived in my Mail inbox. I also sent a test email to another address and it arrived straight away. I did nothing and changed no settings, but the issue seems to be resolved for me (at least right now).


It would be nice to know what actually happened though...

Private Message TalkTalk
Message 9 of 61

Further to my messaged above. I clicked on the Change option in Email account settings and it had Incoming server set as

the Outgoing server smtp, To the side, a test account setting option. So I thought I'd click on that just to check before changing a thing and bingo my emails came straight in. I had not changed anything.

So my advise before going through changing anything, try the above the above, it worked for me.

However, what a waste of my valuable time and all the others on here, who are actually paying TalkTalk for a service.

Its an outrageous way to treat customers.


Message 10 of 61

My double posting was due to clicking on a wrong reply icon the first time and then realising/correcting by replying to the intended post.  It's the first time I've used the support website for several years, so struggling to find my way through it effectively as a newbie again.


I've made the suggested changes  to the POP and SMTP server names in my Thuderbird client and I'm now up and running again. 


I'm afraid TalkTalk's Help content on the TalkTalk Mail Hub is not on my regular bedtime reading list - I have a life to live.  I think I should reasonably expect any customer-focussed supplier to pro-actively notify me, if it is making any changes that require action from me.  I've checked back through my e-mails and there is nothing there from TalkTalk about the change it made this week.


I absolutely agree with Angela91's comments (message 10 in this forum).  TalkTalk's management of this change and its communication to customers is a perfect example of how not to do it. 


I, for one, have wasted at least 4 stressful hours trying to get resolution, not to mention dealing with the consequences of being without e-mail for a whole day.  Heaven knows how much time others are still wasting on this, as well as the support staff time that's being eaten up.  Talktalk really need to learn some lessons from this, but sadly I fear they won't.


If anyone asks me what it's like to be a Talktalk customer, They're not going to get a very positive response.


Message 11 of 61

Hi thanks for this'

In my account settings for email, it has my email address and next to it POP/SMTP ( send from this account by default)

There are options New, Repair, Change.

I tried repair and it came up with a message : an encrypted connection to your mail server is not available. What does that mean?

How did you check for port 995 etc.

I thought I had done this sometime ago.


Message 12 of 61

Hi Gondola


Ah, that makes sense. Thanks for clarifying. 

Message 13 of 61

Hi Ann


Thanks for confirming your IMAP email account is working with secure port 993 for incoming mail.


Port 995 is for incoming mail to POP3 email accounts.


So, users need to know whether they've set up their mail account for IMAP4 or POP3.

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

Message 14 of 61

Hi Lynnpash


Although most of the recommended settings work for me, 995 doesn’t work for incoming mail for either of my tiscali accounts and I am instead using 993 which does work for me. I don’t know whether this is helpful but thought it was worth saying.






First Timer
Private Message TalkTalk
Message 15 of 61

I am also unable to send or receive my messages on my MacBook Pro.  I have to log into talk talk mail.   Two days now and nothing has happened. Its very frustrating. Did you get a response from Talk Talk?


Message 16 of 61

I am not staff but if you make a note of what you have before you change, then change to the new recommended settings you can always reinstate if you have no success.  You will not lose any email from Outlook by changing the server settings.

You need:

POP settings - port 995 incoming (SSL/TLS required),

SMTP settings - port 587 outgoing (STARTTLS encryption and outgoing smtp requires authentication).


Message 17 of 61

I have changed mine and those of a friend in the last hour and we are both receiving email again.  These are the settings you need for Tiscali and PIPEX email to work in Outlook.  If you get email on your mobile phone you will have to change your imap settings too.

POP: port 995 incoming (SSL/TLS required),

SMTP: port 587 outgoing (STARTTLS encryption and outgoing smtp requires authentication).


Private Message TalkTalk
Message 18 of 61


I'm M/S 365. I cannot afford to lose my emails.

As far as I know I am on the settings you have listed for Pop 3 and 995. I have changed nothing.

Its clear to see there is still a major fault from the latest posts. No updates on the service hub, only engineers are working on it, that was 15 hours ago. I've been without outlook since I logged on yesterday at 8am.

This is not acceptable


First Timer
Private Message TalkTalk
Message 19 of 61

My email is still not working today, could a staff member please reply and update me on exactly what is happening?


I have five Tiscali emails, four of which I use in Mail (Win 10 PC), and I noticed yesterday that I couldn't send or receive any. I am getting no error messages and any emails I attempt to send just sit in the outbox. G Mail works fine so the problem is not on my end.


After reading through this thread; is it true that Talk Talk has changed the settings without notifying customers? Is it true that I have to change the settings? If so; what to for my old Tiscali emails? Or, is this some kind of other error on Talk Talk's end?


I notice that some people in this thread have changed settings and it worked for them, while for others it did not. I do not want to start messing around with settings until I get an official response from a staff member.


Please advise...


Popular Poster
Private Message TalkTalk
Message 20 of 61

Apparently TalkTalk decided to enforce a change in server settings without notifying any customers.  I have changed to port 995 and port 587 and have received some mail.  This really is not good enough on so many fronts: lack of communication to the customers; agents on chat not aware of the change; agents on chat not briefed to go over the settings with customers who actually managed to get a chat session; lack of service status update; constant noise that 'our engineers are working on it' when there has been a clear and uncommunicated policy decision.  And of course we will get the usual garbage that there is no compo for being without email for 24 hours because our email addresses are a 'free' service.  Of course we would not have those email addresses if we were not paying an exorbitant amount for an unreliable ISP which is the laughing stock of the IT community.