Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sagemcom Wi-Fi Hub Router Firmware

jimpy
Chat Champion
Message 8 of 8

Over last few days I have had trouble with tv dropping out and slow broadband at times then got a message saying that the Router Firmware needed updated, switched router off for 30 minutes still no joy, tried a reset by pushing reset button on router but it seems the firmware has still not updated.

Spoke to lady on chat line and after 45-50 minutes was no further forward and could not get any real help or information what the problem was, the only response I got was I am carrying out tests! And will be with you in a few minutes, gave up as was just wasting my time.
Can anyone give any help how to update (And What is latest firmware and how do I do a quick check to find out what firmware) or is the router just giving up?

The router does seem to be working most of the time but a little slow and the TV buffers at times, have done both wi-fi and Ethernet speed tests and both are running slower than normal 

Thank You ! Posted By Jimpy From Staffordshire
0 Likes
7 REPLIES 7

Message 1 of 8

Skynet_TX
Community Star
Message 2 of 8

@Michelle-TalkTalk, my Sagemcom updated to v136 last Thursday night, Service Centre was still telling me my firmware needed upgrading until Sunday, but now Service Centre is all happy. So looks like it just takes Service Centre 2 or 3 days before it recognises the router is running the new v136 firmware.

Message 3 of 8

Hello,

 

Apologies, we have fed this back to the team to update this so that Service Centre can identify the correct version of firmware. Thanks for the update and please let us know if this does happen again.

 

Thanks

 

jimpy
Chat Champion
Message 4 of 8

Hello 

Have checked and yes router is running latest firmware all though it’s still telling me to update.

The whole broadband system seems to running a lot better this morning (TV, and wired appliances) so once again many thanks to the community support team for there help and knowledge.

Thank You ! Posted By Jimpy From Staffordshire
0 Likes

Message 5 of 8

Hello,

 

I've checked and the router does have the most recent version of firmware. The line test is clear, however I can see re-connections on the line. Does your main socket have a test socket please? Is their any noise on the voice service?

 

Thanks

 

jimpy
Chat Champion
Message 6 of 8

Hi skynet_Tx,

thanks for info about firmware and how to check,

The light stays on white but have just been told there is a lot of work by open reach going on in our area, so wonder if that could be part of the problem, most of the problems are by wired using main’s adapters, will check firmware number and give it a couple of days then report back

Thank You ! Posted By Jimpy From Staffordshire
0 Likes

Skynet_TX
Community Star
Message 7 of 8

Hi @jimpy,

 

It is highly unlikely the issues with dropping out are anything to do with the firmware. But to check what firmware you are on you can browse to the router login screen at http://192.168.1.1/, towards the bottom of that login screen it will say 'Version' followed by the current firmware version of your router (it will start with SG4K), the latest firmware version is SG4K100136.

 

You can't update firmware yourself, firmware just installs automatically overnight, so given time your router should just upgrade by itself. If for some reason it did not upgrade then the support team here can push out a firmware upgrade manually.

 

If your router is already on SG4K100136 then it is probably just that the Service Centre has not updated yet, as it can take 2 or 3 days before the service centre picks up the fact that you are on a new version of firmware.

 

In terms of your connection problems, are both the wired and wireless devices affected. Does the white LED go out and flash orange when you have issues, or does the LED always remain solid white.

0 Likes