Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Broadband
Have a question about our totally unlimited broadband? Why not ask the community a question.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Forum Posts

Privacy warning - this network is blocking encrypted DNS traffic

This subject is involved & not knowing how much you know, or want to know about it, I will try to explain. When you type a website address URL in the browser this must be converted to an IP address, as the URL is not rotatable, only an IP address is....

Weak Security Warning on Apple IOS and Windows 10 or 11

Some Apple products have recently had an upgrade that can show the WiFi connection as having weak security:- iPad Software Version 14.01 - since the update to Version 14.0 it has shown Weak Security iPhone SE Software Version 14.01 -since the update ...

Vpn connection issues

Hi hopefully you can help I work from home 2 days a week recently when I have tried logging in it won't let me log on to VLN it's saying errors messages unable to connect secured please contact provider

Lainy61 by Visitor
  • 63 Views
  • 6 replies
  • 0 like

VPN connection Problem

Hi everyone, I have the exact same problem as a few other people here. I lost connection with my work VPN after 2 years of connecting without any issues. As I saw few other people faced the same issues caused by the router firmware. I tried to speak ...

Elena15 by First Timer
  • 94 Views
  • 7 replies
  • 0 like

My VPN has stopped working sin May 2022

HiI have been using the TalkTalk FAST 5362 and as of 5th May 2022, I am unable to VPN into my office. It was working ok until then, and on that day I lost the internet so called TalkTalk who advised me to reset the router, which I did and it all seem...

myerl by Sightseer
  • 102 Views
  • 4 replies
  • 0 like

Ring Camera with latest Router firmware

Hi - can anyone confirm they have their Ring cameras working ok with the latest Sagem Fast5364 router firmware (SG4K100136 I believe)? Our Ring cameras communicate on the local network ok but we can't see any video (goes from camera to Cloud/Ring.com...

SoF00 by Team Player
  • 116 Views
  • 7 replies
  • 0 like

Vpn connection not working

I have been working at home for 2 years. I am unable to connect to my work network. I understand on 21/4/22 there was an update. Please can you update my router as I need to work at home tomorrow. Thank you

Dopey3 by Sightseer
  • 129 Views
  • 6 replies
  • 0 like

PS5 refusing to connect

Recently my sons PS5 will not allow him to connect to PSN/Chat/Play games.I've tried adding the PSN rule in the firewall, tried setting it to a DMZ but the only way it will connect is if I disable the firewall entirely, which I'm not willing to do. I...

Sagemcom FAST 5364 Router Issues - Firmware upgrade

Hello,I've been having problems with -1. Work VOIP phone has stopped working since - 02/05/22 - when the router had a firmware upgrade.2. Smart meter display stopped connecting to the internet3. Work VPN - As a lot of ppl have been saying in this for...

Can't access VPN since last week

Hi there! I have been unable to access my VPN since last week and have seen some others have had similar issues - the problem being a firmware update to their router? I can access using other locations. Please can someone look into this for me?Many t...

ArchSB by Newbie
  • 205 Views
  • 9 replies
  • 0 like

VPN issue

My partner cannot connect to her work VPN, I believe that there is some software issue, can the firmware be updated please

Bryn72 by Newbie
  • 125 Views
  • 7 replies
  • 0 like

VPN NOT CONNECTING USING PPTP

My partner is having problems connecting to her work VPN. It was all working fine until this week has something been changed ie software etc. Can a firmware update be done to resolve this?

VPN WhatsApp and Firewall Issues

Sagecom WiFi hub. Firmware ending in 136 Adding my query/comment to the growing pile of similar on here Since Monday 2 May work VPN does not connect, nor Bosch EasyControl thermostat. WhatsApp “thinks about it” before displaying messages, and similar...

ggttjm by Popular Poster
  • 205 Views
  • 8 replies
  • 0 like

VPN Issue

Hi, Like it seems many other users, I am having the same issue as: https://community.talktalk.co.uk/t5/Broadband/VPN-CONNECTION-ISSUE-Generic-Routing-Encapsulation-GRE...https://community.talktalk.co.uk/t5/Broadband/VPN-no-longer-working/td-p/2883303...

Your broadband connection is healthy but updates are required

FAO Support Team Can you please look into this issue apparently with my router software?When I check my line I receive a message as follows:- 'Our health check on your service shows that your router software requires an updateOur health check shows t...

Giraffe by Wise Owl
  • 320 Views
  • 15 replies
  • 0 like

Firmware update Sagemcom Fast5364

Hi all, My internet recently just randomly went down out of the blue. I reported a fault and it looks like my Sagemcom Fast5365 router requires a firmware update. I work in I.T myself so I understand that a patch just needs to be applied for the late...

Sagemcom Wi-Fi Hub Router Firmware

Over last few days I have had trouble with tv dropping out and slow broadband at times then got a message saying that the Router Firmware needed updated, switched router off for 30 minutes still no joy, tried a reset by pushing reset button on router...

jimpy by Chat Champion
  • 238 Views
  • 7 replies
  • 0 like

Unable to Access Plex and Discord

I am unable to access Plex and Discord voice services (stopped working recently). I have a Sagemcom Fast 5364 router with SG4K100136 software.If I replace the router I can get to both services so it appears to be a router issue.Does anyone know how t...

TimkT by Team Player
  • 137 Views
  • 5 replies
  • 0 like

firmware upgrade slow home network

Hi, my #sagemcom #router has recently upgraded firmware to #SG4K100136 from ...2816t (I think) and the home network connection to NAS drive has become unworkably slow. The connection to the internet is fine but no better than before the update. Any c...

Fast 5364 Firmware Update

Good morning, continuing from posts I added on Friday 29th April is it possible a forced firmware update can be pushed through to my router? The logs appear to show the hub is making attempts during a period between 00:00 - 04:00 but without success....

SteveyMc by Conversation Starter
  • 134 Views
  • 2 replies
  • 0 like

SAGEMCOM FAST 5364 TALKTALK ROUTER - Hardware Failure

I have a SAGEMCOM FAST 5364 TALKTALK ROUTER - Wireless Hub with VDSL2/ADSL2 Modem for fibre, which has died.HARDWARE version: FAST5364 3.00FIRMWARE version = SG4K10002816tIt stopped working at 5.50am BST, the network went down and the LED was permane...

steve1234 by Conversation Starter
  • 1167 Views
  • 56 replies
  • 2 like

Firmware Update

My router says it needs an update. Please could you send me the file so I can do it myself?

Out of date firmware FAST 5364?

Hi @Chris-TalkTalk My Sagemcom FAST 5364 is still running SG4K100124 firmware. If this is old could you update it for me please? Whenever I do a self service check it tells me that it's out of date. Thanks a lot in advance.

fre55die by Community Star
  • 462 Views
  • 21 replies
  • 0 like
Labels