Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sky Minibox Hotspot Activation problem

kasapeky
First Timer
Message 4 of 4

Hi,

I have Talktalk Broadband and Sky Q TV with 2 x miniboxes feeding satellite TVs.

 

You can make the miniboxes into WiFi hotspots, which is ideal as 1 of the miniboxes is wired to a room with no wifi.

 

Problem is, Sky Main box won't activate the hotspots as it says "your router's wifi security doesn't meet our min requirements. ..contact your broadband provider to see if they can update your router to have WPA2 security"

As far as I can see the router has WPA2 security.

I have called Sky and Talktalk and both say they can't do anything and I should call the other!

 

Anybody got any ideas?

Thanks

Pete

0 Likes
3 REPLIES 3

Message 1 of 4

Hi kasapeky 

 

WPA2 Personal is good. The Sky Q Box should accept this security setting. As the Sky Help Guide for this feature says "you may need to restart your router/hub and try the setup again"

 

 How to enable WiFi Hotspots for non-Sky Broadband lines

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

Message 2 of 4

Hi Gondola, I replied earlier but it seems to have disappeared. Have checked and have WPA2 Personal for security. I know there is WPA2 Enterprise but am scared to mess with that. Still not resolved.

0 Likes

Gondola
Community Star
Message 3 of 4

Hi kasapeky 

 

You're right that the TalkTalk Wi-Fi router / hub does have WPA2 security. Try setting the security to just WPA2 only.

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution