Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VPN does not work

Ane4ka_1
First Timer
Message 11 of 11

Good evening.

I've seen quite few posts on this forum regarding VPN not working. I have the same problem. I am not quite sure how long ago it has started as I haven't worked from home for a while but recently I needed to connect to my work computer and I could not get it working. I took it on with the IT department at work who told me there is nothing wrong with my VPN settings and I need to talk to my Internet provider. 

I then discovered that many people experience the same problems with VPN, something to do with the firmware updates and in some instances getting a new router helps the issue.

I've called TalkTalk on Saturday and the adviser was not trained in VPN issues but kindly offered to send a new router to me which I've received today. The problem that I have now is that the new router does not want to connect. I keep getting flashing white/amber light for about 2 minutes and then it turns solid amber. I've waited over 15 min as suggested in the instruction manual but it does not seem to be fixing anything. I've tried few times, used my existing cables and new cables provided with no luck. Connecting old router fixes the issue with Internet connection but I now don't know what to do.

If anyone could give me any guidance it would be very much appreciated. By the way the old and new routers are both Sagemcom.

Many thanks

0 Likes
10 REPLIES 10

Message 1 of 11
0 Likes

Message 2 of 11

Yes, I have. I will get it returned next week. Thank you

Message 3 of 11

Cool, thank you for your help.

Message 4 of 11

Morning,

 

I'm really glad to hear this. Did you receive a router returns bag?

 

Thanks

 

Skynet_TX
Community Star
Message 5 of 11

If the new router came with a returns bag and pre paid label then you could return it in that. If you didn't get a bag / label then post back here to let us know and one of the support team would be able to send one to you.

Message 6 of 11

Hi Debbie, 

 

I can confirm VPN is now working! Thank you very much for your help.

 

What shall I do with the new router I've received? Can I send it back?

Message 7 of 11
0 Likes

Message 8 of 11

Hi Debbie,

 

Thank you for your reply. I am currently at work but will be able to test it this evening, I will let you know how I get on once I am back home.

 

Many thanks

Debbie-TalkTalk
Support Team
Message 9 of 11

Hi Ane4ka_1

 

I'm sorry to hear this.

 

I've made a change to your router firmware, please can you retest?

 

Thanks

 

Debbie

Skynet_TX
Community Star
Message 10 of 11

Hi @Ane4ka_1,

 

You could try a factory reset of the new router by holding in the reset switch on the back for over 10 seconds.

 

However the issue with your original router can probably be fixed by the support team here.  If you have the Sagemcom Wi-Fi Hub then this VPN issue will probably have been caused by the firmware upgrading to a new version.

 

What VPN software do you use, or is it the built in Windows 10/11 VPN ?

 

The support team here will be able to help, they will probably be able to fix it by changing some router settings or changing the firmware, they will hopefully be able to reply tomorrow.

 

Even if you did get the new router working, it may also be on the same version of firmware that would give you the same VPN issue, or if not, it would likely upgrade itself to that version within a few days.