email support

Ask us about your TalkTalk email account and Webmail.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webmail: No spam but spam folder is always empty

First Timer
Message 6 of 6


I never have any spam in my inbox, but when someone sends me an email and I don't receive it I look in the spam folder, but it is always empty. In fact I don't think I've ever seen anything in the spam folder. How can I recover these missing emails if I can't see them in the spam folder to mark them as not spam. Webmail seems to just nuke anything that it doesn't like the look of.




Message 1 of 6

If you now receive the email because you added the email address to a Safe Senders Contact List linked to an email client like Outlook then that's good. The email client will show that mail message in the Inbox and never put it in the Junk folder.


Adding the email address to the TalkTalk Mail Address Book has no effect on the deliverability of mail to your online mailbox. 


Mail is put in the online TalkTalk Mail Spam folder if it's been marked as spam either by you the user or by the inbound mail assessment and it comes in with a spam flag / spam score. 


You're still not giving the full story of how you're using email. 

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

Message 2 of 6

Hi, I'm not sure if they got a bounce back. I don't think so as they would have known it wasn't delivered and contacted me. I have now added that specific email address to my address book and am now receiving those emails OK. I think the problem is bigger than one unreceived email though. As I stated originally, my spam folder never has anything in it, so I can never check it and reinstate any messages that the systems thinks suspicious. I don't know if this is a hangover from the old webmail from the tiscali days as I don't remember that having a spam folder you could access. It would be nice to get to the bottom of it.



Message 3 of 6

Hi A-D-K 


In the situation you describe, that mail from a domain is normally received but one from the same domain is not, would suggest either that the email address is detected and filtered or the content is considered harmful and not delivered. 


In the case of suspicious content I'd usually expect the inbound mail filters to issue a bounce back error message to the originating email address to advise of content scanning / non-delivery. 


Do you happen to know if that happened?


Is this a general enquiry or do you need help to identify a deliverability issue with a specific address or domain?

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution

First Timer
Message 4 of 6

Thanks for your reply. I don't have any filters set, so I don't think it's that. Also, as I said in my original message, there is never anything in my Spam folder. I know of at least one recent work email that didn't arrive, even though I've received plenty of other emails from people at the same company.


Community Star
Message 5 of 6

The Spam folder will contain mail that arrives in your Inbox and that you Mark as spam. The contents will remain for up to 30 days before auto-deletion. 


The Spam folder would also contain mail that the TalkTalk assessment via CloudMark deems via an inbound mail check that the mail has probably been sent by a spam sender or is fingerprinted as spam. 


If mail doesn't arrive it may have been detected as suspicious so is deferred for scanning. If the mail makes it through the scanning process it will be delivered later. Mail could be dropped if the scanning process confirms that the contents are spam. 


Let us know if you don't receive mail that you're sure isn't spam. 


But first check that you don't have anything set up to divert or block mail from arriving in your Inbox. 


Mail not reaching the Inbox could mean there's a Filter rule, including an Auto forward which is a special filter rule, that's diverting, discarding or blocking mail.

  • To check, select the Main Settings menu icon      triple line icon top right on the blue header
    (Mobile browser? use the desktop version)
  • Select Settings from the top of the menu
  • Select the inward facing arrowhead by Mail (or Email) in the left side panel
  • Select Filter Rules
    If there's no rule defined, that's perfect
  • To delete a Filter rule including any Auto forward
    select the Dustbin icon    to the right of the rule
    The icon background will turn red    
  • To confirm you really want to delete this Filter rule
    Select the blue Delete button

GondolaVolunteer 2017-2022

  Like below to appreciate my help . . . Mark as solved  Accept as Solution