Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EchoLife DG8041W (1.06t) dropping connection to internet

Pickus
Chatterbox
Message 6 of 6

My router seems to be gradually failing and dropping connections. I can connect to the router over wifi no problem and it shows no internet connection. I'm increasingly having to hard reset to resurrect connection. Is there any firmware update that I'm missing on this device or is there something else going on? Any help would be appreciated.

Steve

Steve Harper
0 Likes
5 REPLIES 5

Message 1 of 6

Hi Steve

 

Sorry for the delay.

 

The router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 2 of 6

Hi, when I have the issue, the LED does change from solid white and will flash as it does when connecting.. it will go to solid white once it's settled down and I can continue to work. The line has been tested and shows no fault, however, Debbie from TT has offered a replacement router to see if that can pinpoint the issue.

Steve

Steve Harper
0 Likes

Message 3 of 6

Hi Debbie,

Thanks for the update on line test, good to know it's not a line fault. If you think a replacement router may help to narrow down the issue then, yes please, I will give that a try...

Many thanks

 

Steve

Steve Harper
0 Likes

Debbie-TalkTalk
Support Team
Message 4 of 6

Hi Steve

 

I'm really sorry to hear this.

 

I've completed a line test which hasn't detected any faults.

 

Would you like me to send a replacement router for testing to see how the connection compares?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 5 of 6

Hi @Pickus,

 

1.06t is the latest firmware version for this router, does the LED remain solid white when you have these issues, or does it flash amber or amber/white ?