Home Phone

Get help with your TalkTalk landline and calling features.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No ringtone.

emmpet
Conversation Starter
Message 21 of 21

I had loss of landline phone and broadband.

It took TalkTalk two months to sort the problem out. The problem was cured when an engineer put a new wall socket into a different place on my wall.

My phone, TV, and router, were then all close to each other.

After a few weeks, people told me that they had rung me, but had no answer.

I finally realised the phone was working, but had no ringtone.

So, I bought a new phone. All was well for a short while, then I seemed to be getting missed calls again.

Yesterday, I had an appointment. I was told the man would ring me when he was on his way.

He eventually arrived, and told me he had rung, but got no answer.

I got my mobile, and rang my landline. The ringtone was heard on my mobile, but the landline phone was silent.

I went into your help section. The problem was not covered, but it did say that the wall socket should be checked.

It is situated behind the TV. So I moved that, and discovered that the bottom right hand side of the cover, was not fitting flush. I tried pushing it into place, but it kept popping back out.

I wonder if this is causing the problem, as the phone is connected into that side.

I have been trying to find a telephone number, to ring for help, but can't find it.

This is why I am telling you the whole story. 🙄

PS. I am of the 'old school', and do not understand technical language.😕

0 Likes
20 REPLIES 20

Message 1 of 21

Hi emmpet

 

That's great, thanks for letting us know 🙂

 

Debbie

0 Likes

Message 2 of 21

Sorry for the delay.

All sorted. Still working.

Thank you.

Message 3 of 21

Hi emmpet

 

Sorry for the confusion. I've just checked and the appointment is still showing for 22/04 AM (8am - 1pm)

 

Please let us know how you get on following this visit.

 

Thanks

 

Debbie

0 Likes

Message 4 of 21
I have just noticed a message left on my answerphone.
It is a recorded one from Open Reach about my appointment tomorrow - Thursday. I was asked if I still wanted the engineer, and to press 1.2.or 3.
Well, of course I couldn't do a thing about it as the message had come at 4pm. And it is now after 8pm.
I shall never understand TalkTalk's way of doing things.
0 Likes

Message 5 of 21

Hi emmpet

 

I will add notes to the fault ticket to request this.

 

Thanks

 

Debbie

0 Likes

Message 6 of 21
That is fine, thank you, Debbie.
Just tell him not to do what someone tried to do last week - try to ring to tell me he is on his way.
0 Likes

Message 7 of 21

Hi emmpet

 

Thanks for confirming your details.

 

I have arranged the engineer visit for 22/04 AM (8am - 1pm)

 

Will this date and time be ok?

 

Thanks

 

Debbie

0 Likes

Debbie-TalkTalk
Support Team
Message 8 of 21

Hi emmpet

 

I'm just sending you a Private Message to confirm some details so we arrange an engineer visit.

 

Thanks

 

Debbie

Message 9 of 21

@ RoyKR.. When I press the green button on my phone, I do get a ring tone.

 

@ Michelle. What you say is correct. And I agree about an engineer being needed.

Thank you.

0 Likes

Message 10 of 21

Hi RoyKR,

 

I'm really sorry to hear this. I've just posted on your other topic now.

 

Thanks

 

0 Likes

Michelle-TalkTalk
Support Team
Message 11 of 21

Hi emmpet,

 

Thanks for the photo. Can I just confirm, if you test 2 different phones at the test socket with the microfilter removed, does the phone still not ring if you call the landline from a mobile? If this is the case then we should arrange an engineer visit if you're happy to go ahead with this?

 

Thanks

 

Message 12 of 21

Hello EMMPET,

INFO' NOTE - TALK TALK hope to get this fixed by 7th May.

 

I've the same problem and have just posted this:- 

 

We have been self isolating and are always at home - BUT Apparently, for about the last 3 weeks, callers phoning my landline are getting "Ring tone, but no reply" - and our phones are not ringing! - just sometimes there is a a tiny squeek/ring from our phones and when we pick up no-one is there. Then we put the phone back, pick up and we DO NOT GET dial tone. Put the phone back and pick up again and we DO GET dial tone.

Calling the TALK TALK 0345 help number yesterday, I was advised this is a current KNOWN PROBLEM and is hoped to be fixed by 7th MAY. OK, that's about 6 weeks of a disruptive service.

Where was this information posted on TALK TALK Customer disruption of Landline Phone service please? Would have saved me time on the phone call and posting here again.

Regards

RoyKR

Roy Riches

Message 13 of 21

Hello Michelle.

I have taken a photo.

Not very good, as it is in a small area, and is dark there.

I couldn't get the rest into the photo, but the other socket has the router and phone plugged into it.

Hope this helps.

Thank you.

IMG_0226.JPG

0 Likes

Michelle-TalkTalk
Support Team
Message 14 of 21

Hi emmpet,

 

Thanks for trying this. Can I just confirm, was the microfilter connected to the test socket behind the faceplate? Is the phone still not ringing with 2 different phones? If this is the case then we will need to arrange an engineer visit to the property to investigate this further.

 

Thanks

 

0 Likes

Message 15 of 21

What is CallSafe?

I have just got around to trying the Microfilter. There were two in the router box.

I followed the instructions. No difference. I took the router cable out - still the same. I took the Microfilter off, and put the phone cable straight into that socket. No luck.

Each time I tried something, the telephone screen lit up, with - CALL and my mobile number (which I was using).

And, as previously, I could hear the landline ring tone on my mobile.

I then got the other Microfilter from the box, and tried everything again.

No luck.

I think this all has to do with when the engineer came, and fitted new wiring, and socket box.

As I said previously, this has happened with two phones since then.

I will now go and do a search for CallSafe.🙂

Found it. No, I don't have CallSafe.

0 Likes

Michelle-TalkTalk
Support Team
Message 16 of 21

Hi emmpet,

 

I'm sorry for the delay. How are you getting on? Are you using CallSafe?

 

Thanks

 

0 Likes

Message 17 of 21

Thank you Michelle.

I shall try that in the morning.

I have just discovered that I can't get into my bank account, as they are unable to ring me with a security code.

0 Likes

Michelle-TalkTalk
Support Team
Message 18 of 21

Hi emmpet,

 

Sorry for the delay. You would connect the microfilter, router and the phone at the test socket. I've included a Help Article below which provides more information on microfilters.

 

Your guide to microfilters

 

Thanks

 

0 Likes

Message 19 of 21

Yes, it does.

I went to your link, and it says - 

  1. If you're testing your router, plug a microfilter into the test socket.

It doesn't mention the telephone line.

And I don't have a clue what a microfilter is.

 

Thank you.

0 Likes

Michelle-TalkTalk
Support Team
Message 20 of 21

Hi emmpet,

 

I'm sorry to hear this and I will take a look now. I've run a few tests on the line which are all clear. Does the main socket have a test socket?

 

Your guide to main phone sockets

 

Thanks

 

0 Likes