Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Drastic drop in speed since contact renewal

steveyboy
Team Player
Message 19 of 19

I recently renewed my fibre contact but since then my speed has dropped significantly...I've re-booted the router, changed cables etc but that has made no difference.

0 Likes
18 REPLIES 18

Message 1 of 19

Hi steveboy,

 

Do the routers have built in fibre modems or are they just routers?

Please also see Our guide to Future Fibre

 

Chris

0 Likes

steveyboy
Team Player
Message 2 of 19

Thanks for the info regarding fibre speed..I assume that in my area it's only Fibre to cabinet and not to home?

If this is the case, can I use a normal router? I have a firewall router that I was thinking of attaching and also quite a good netgear router.
Also, do you know who I would contact about finding out if full fibre to home is planned for my area.

0 Likes

Message 3 of 19

Hello,

 

Thanks for the update. Yes they are just regular microfilters.

 

Thanks

 

0 Likes

steveyboy
Team Player
Message 4 of 19

Thanks for your help, the speed seems to be sorted out...I think it was possibly the filter. I don't have a spare one so I temporarily borrowed from a friend.
I'll try to get a new filter, the one I was using was from Talktalk.
Is it just a normal filter?

0 Likes

Message 5 of 19

Do you still hear the noise on the telephone line if you just have your telephone connected and disconnect your router?

 

There isn't really a way to speed up your current connection on FTTC as your speed is mainly limited by the length and quality of the cable from your home to the street cabinet 

 

Chris

0 Likes

steveyboy
Team Player
Message 6 of 19

I don't think I have another filter, so unfortunately I can't try it out.

Thanks for the info on fibre65..Is there a way of speeding up my current connection?

0 Likes

Message 7 of 19

Hi steveyboy,

 

Yes those speeds are around what we would expect.

 

Yes it could be the filter, do you have another one that you can test with?

Upgrading to Fibre 65 just removes the 40Mbps cap so unfortunately there would be no benefit in upgrading to Fibre 65 for yourself as your sync speed is currently well below 40Mbps


Chris

0 Likes

steveyboy
Team Player
Message 8 of 19

Thank you, I've just had a chance to try it out, disconnecting the phone and the router appears to have sorted it out...I've run a speed test and I'm now getting 24.1 download and a 4.1 upload speed.

Does this seem correct?

 

It just leaves me with the problem of connecting the phone. Is it possible the filter is causing the problem?

 

Also, would you be able to tell me when fibre65 will become available in my area?

0 Likes

Message 9 of 19

Hi steveyboy

 

How are you getting on following the 30 minute power down of the router?

 

Thanks

 

Debbie

0 Likes

steveyboy
Team Player
Message 10 of 19

OK, thanks. I've tried disconnecting the router but it was only for about 5 mins...I'll try it for 30.

0 Likes

Message 11 of 19

OK thanks. Can you switch your router off and leave it off for at least 30 minutes, then switch back on and retest - please let us know if there's any improvement

Chris

0 Likes

steveyboy
Team Player
Message 12 of 19

At the moment, a few sites I download from is showing that I'm downloading at app. 450 kb/s, normally these same site download at approx, 990 and above.
A speed test, done with talktalk shows that I'm getting 3.7 download and 4.3 upload..usually upload speed is less than download speed.

0 Likes

Message 13 of 19

OK thanks, have you noticed an improvement in speed?

Chris

0 Likes

steveyboy
Team Player
Message 14 of 19

Yes, the phone is still disconnected..

0 Likes

Message 15 of 19

Hi steveyboy,

 

Is the phone still disconnected? Your sync speed is now 26Mbps


Chris

0 Likes

steveyboy
Team Player
Message 16 of 19

I've tried disconnecting the phone, but the speed still seems to be approx. half (or worse) of what it was previously.

0 Likes

steveyboy
Team Player
Message 17 of 19

I just tried the phone line and therev seemms to be a slight hissing sound on it...I rarely use the phone and only just recently plugged the phone back into the socket.
Could the phone be causing the problem?

 

Thanks

0 Likes

Michelle-TalkTalk
Support Team
Message 18 of 19

Hello,

 

I've run a test on the line which has detected a potential fault. Are you experiencing any issues with the voice service such as noise on the line or no dial tone?

 

Thanks

 

0 Likes