Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

WiFi connection keeps dropping

Daham
First Timer
Message 3 of 3

All devices in the home using WiFi lose connection to the router multiple times per day. Wired devices never lose the connection. When this happens odd devices complain about an authentication error. It seems to be a problem with the router. Any advice?

0 Likes
2 REPLIES 2

Debbie-TalkTalk
Support Team
Message 1 of 3

Hi Daham

 

I'm really sorry to hear this.

 

Please can you add your name and TalkTalk landline number to your Community Profile, we can then look into this further.

 

Thanks

 

Debbie

Skynet_TX
Community Star
Message 2 of 3

Hi @Daham,

 

If wired devices are ok, and you only have issues with wireless devices, then this could be caused by Wi-Fi interference, e.g. a neighbour could have a router broadcasting on the same, or similar, channel to yours.

 

You could try changing the channels that your router broadcasts the Wi-Fi signal on, you can use free smartphone Apps like this to see what channels are being used within range of your smartphone, you can then change your router to use channels that are less congested.

 

If trying this makes no difference then it may indicate an issue with the router, the Support Team here would be able to help with that.

 

I'm not sure what router you have, but be aware that the Sagemcom router has a feature called 'Wi-Fi Optimisation', this means it can change the Wi-Fi channel itself, overriding what you have set it to, it can randomly do this after minutes, hours or days !. So if you do find a channel that works well, but then things go bad again, check to see if the router has changed channel to something different to what you set it to. If you do experience this problem then just post back here to ask the Support Team to disable the 'Wi-Fi Optimisation' on your router, once that is done it will stay on whatever channel you set it to. This only affects the Sagemcom Wi-Fi Hub, if you have the Huawei Wi-Fi Hub it will stay on whatever channel you set it to.

 

For one of the TalkTalk Support Team on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile (only you and the TalkTalk Support Team on this community can see your profile details).

 

Then they will hopefully be able to respond to this post tomorrow.