Showing results for 
Show  only  | Search instead for 
Did you mean: 


We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

anydesk not working since full fibre upgrade with new router

First Timer
Private Message TalkTalk
Message 6 of 6


Since being changed to full fibre last week, and getting a new router, anydesk no longer works and gives "the unable to connect to server" message.

From what I've read so far, it looks likely to  be the router stopping the access to my Galaxy Android Tablet. 

It seems to need a port forwarding rule set up on the router.

I guess I'm too thick to set up the port forwarding on the router, all I know is that I have to put 80 or 443, or 6568 but I don't even know if that is for the internal or external setting. But I've usually sorted out these things before.

Do I have to give my Galaxy tablet a fixed IP address ? I can manage that if it's required.

I think the internal host port would be one of the 3 possible above to allow anydesk through, and I suppose the internal host IP address would be for my tablet - with static IP address, and the external host IP address would be the router gateway IP address, not sure what the external host port would be.

Anyway that's probably all wrong, so if anyone can help I'd be very grateful.

The  scam protection control is set to off in my talktalk account - it didn't change with the new router


Message 1 of 6

Glad to hear that there's been some improvement. So what you are trying to do here worked fine before upgrading to Full Fibre?



Message 2 of 6

Hi Chris


I've finally managed to get on the forum to reply, more luck than judgement, so I'll put my reply here in case you don't see the email.

Thankyou so much, that worked and now I can connect to my Galaxy Android tablet from my pc.

But there is still an issue;

I can connect to the tablet from my laptop. But I get the "waiting for image" message indefinitely. It's definately connected to the tablet because the tablet display becomes active, and if  I use the home or power options in anydesk on the laptop, the tablet responds.

The only way the image displays is if on the tablet I open the anydesk app before connecting, then when I connect I get the message in the tablet anydesk app about "start recording or casting with anydesk" If I allow that on the tablet, then the image is visable on the laptop, but obviously that is not an option when connecting remotely.

It seems there is still something stopping the image being shown.

I don't know if you can help with this, but you have solved the initial problem, so thanks again.


Message 3 of 6

OK thanks, that sounds like the Sagemcom wifi hub 2. When you get home could temporarily change your router's DNS settings too a 3rd party's (googles are and, then check to see if this makes any difference to anydesk 


Using 3rd Party DNS - TalkTalk Help & Support




First Timer
Private Message TalkTalk
Message 4 of 6

Hi Chris

I'm at work now so can't look, it's a new one since getting the full fibre upgrade last week, it has a socket for the telephone it that narrows it down. It is black with the one light. 


Support Team
Private Message
Message 5 of 6

Hi foolonthehill,


Which router do you have?