Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't connect to Wifi, Windows says router not secure.

beppe6
Team Player
Message 12 of 12

Hello,

 

Both my laptops suddenly can't connect to TalkTalk Wifi (possibly after a Windows 10 update?); the message is: "Unable to connect to this network". Nothing has changed: same credentials, security, automatic IP, etc.

 

After many attempts (restarting router and laptops, un- and re-installing  adapters,  looking for newer drivers - but I couldn't find any) I managed to get wifi back on one of them by running the following commands:

netsh winsock reset

netsh int ip reset resetlog.txt

netsh int ip reset

ipconfig /flushdns

 

however it's unstable, when I come back to it usually it's not connected.

 

The other laptop doesn't connect at all. Now I get the following steady message evry time I try connecting: "This wifi network (= the TalkTalk router) uses an older security standard that's being phased out. We recommend connecting to a different network." And then it doesn't let me in.

 

I see that another customer with the same problem resolved it by obtaining a new router.

Mine is a TalkTalk DLink DSL-3782.

Security:  WPA/WPA2

The system is Windows 10.

 

Any ideas?

Thanks.

0 Likes
11 REPLIES 11

Message 1 of 12

Hi beppe6,


Glad to hear that Keith's solution has worked, thanks for letting us know 🙂

Chris

0 Likes

beppe6
Team Player
Message 2 of 12

The solution proposed by @KeithFrench worked for me, many thanks!

beppe6
Team Player
Message 3 of 12

@KeithFrench 

 

I have now changed the WiFi security setting according to your post and things seem to be working better.  I'll confirm in a couple of days, or sooner if problems continue (in which case I'll collect and post the info you requested).

 

Many thanks.

0 Likes

beppe6
Team Player
Message 4 of 12

@Skynet_TX: unfortunately the problem started again, so simply changing channel is not enough.

@KeithFrench: many thanks, I'll try out your suggestion as soon as I have the time.

@Debbie-TalkTalk: problem not resolved yet, I'll be in touch soon.

And many thanks to all of you for your help! 

0 Likes

KeithFrench
Community Star
Message 5 of 12

I have just reconnected a DSL-3782 & set the security mode back to WPA/WPA2, but I do not get any warning when I connect to the WiFi on my Windows 10 21H2 laptop. Perhaps you have a higher specification network adapter in your PC than mine. Please can you go to a command prompt & put in these two commands one after the other and get me the output from them:-

 

netsh wlan show drivers

netsh wlan show interface

 

Thanks very much.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 6 of 12

Well, so far I have not been able to reproduce this on a Sagemcom having set it back to WPA2/WPA Personal. I will need to try this on a DSL-3782, but I can't do that today.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 7 of 12

Since Windows 10 21H2 & presumably Windows 11, they now support the newer security mode WPA3, despite the fact that your router doesn't as yet. WPA2 Personal is still fine. The problem is the older WPA, this should not be used anymore. Your devices should all use WPA2 Personel as this is a negotiated parameter on connection, where the device & router agree on the most secure option that they both support (WPA2), so changing the router to use WPA2 only should sort this. Please see the link I put in my previous post to my "sticky" on how to do this.

 

When I have had the chance to prove that this is the issue I will update the sticky to show it affects Windows as well as Apple devices since iOS V 14. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 8 of 12

Hi beppe6

 

Sorry for the delay.

 

Has this been working ok since your last post?

 

Thanks

 

Debbie

0 Likes

KeithFrench
Community Star
Message 9 of 12

This is most likely caused by the security mode WPA still being an option. Set the router to WPA2 Personal with AES encryption only. Although it seems like my sticky on this subject only affects Apple products, perhaps Windows is now complaining as well, if WPA is a valid option. Please see it at:-

 

https://community.talktalk.co.uk/t5/Broadband/WEAK-SECURITY-APPLE-DEVICES-POST-IOS-14/m-p/2793346#M8... 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

beppe6
Team Player
Message 10 of 12

Hi @Skynet_TX , changing channel has done the trick! I wish I had thought of it before wasting hours on all the rest...

However, the message about the "older security standard that's being phased out" is still there when reconnecting, so I wonder whether this indicates that the router is about to become obsolete?

In any case, it's working for now; many thanks for your help, much appreciated 🙂.

 

Skynet_TX
Community Star
Message 11 of 12

Hi @beppe6,

 

Staff here will be back tomorrow, and will hopefully be able to respond then. If they feel a replacement router is the best course of action they will be able to arrange that for you.

 

Have you tried changing Wi-Fi channels on your router, just in case some Wi-Fi interference is causing this strange behaviour ?