Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XBOX Live not working

pixcellator
Participant
Message 27 of 27

 

I have spent the whole of yesterday evening and some of today  troubleshooting. Tried to call customer support today - of course the phone lines were "too busy" and recommended I call back "in a couple of hours". 

 

I am convinced there is an issue with a recent firmware update or other upstream change on my broadband service which is preventing Xbox Live from functioning.

 

Everything was working fine until last week and now all of this week I have been unable to use Xbox Live. I have removed and reset routers and devices, meticulously added and removed firewall ports until I finally saw the Teredo service on port 3074 appear under UPnP - yet it is still not working. Neither my Xbox Series S nor my Xbox 360 can communicate with Xbox Live any longer, both were working previously.

 

Today I tried using the Xbox on my mobile hotspot and of course it started working straight away. When I came back a couple of hours later and tried the hotspot I had the same issue I now have on TalkTalk, so I pretty much KNOW this is being caused by the ISP.

 

Unfortunately you don't provide access to the latest or historical router firmware or any roll back options, so I'm unable to test that and see if it resolves. Can you roll back my firmware or whatever you have to do to get my Xbox Live working again?

 

I can see that this question has been asked multiple times before with no solution and I'm now slightly past cheesed off, so allow me to be abundantly clear - if this is not resolved on or before Monday I will be cancelling immediately without your permission - contract or no contract.

 

Thank you.

 

Router:  TalkTalk Wi-Fi Hub version SG4K100136

0 Likes
26 REPLIES 26

Message 1 of 27

Hi pixcellator

 

Would you like me to send a different router for testing?

 

Thanks

0 Likes

Message 2 of 27

Hi Michelle. I have tested it over the last couple of weeks. At first after the firmware update and a subsequent router reset it worked as before and the next day it was borked again. I have tried going through alternating sequences on my xbox, if I can summarise the result is that on EE broadband I can more or less always get it to work, but my TalkTalk almost never works.

 

So Xbox gaming on EE has alleviated some of my earlier frustrations but I really would like my TalkTalk sorted.

 

I can see there are now dozens of threads about VPN issues as well - the Xbox uses Teredo protocol which is an IPv4 to IPV6 tunnel, so as before I don't know what has changed, but something has.

 

Can the router be changed? Is there a firmware fix? 

 

Thanks

0 Likes

Message 3 of 27

Morning,

 

Thanks for the update. Is the connection still ok at the moment?

 

Thanks

 

0 Likes

Message 4 of 27

Thanks - first night result is positive. I was able to play Xbox on TalkTalk with no NAT issue and no lag whatsoever following this firmware update.

Screenshot_20220514-100023_Edge.jpg

0 Likes

Message 5 of 27

I'll do the firmware update now, it will take up to 20 minutes to complete, please don't switch off your router

 

Chris

0 Likes

Message 6 of 27

OK, I'll do the firmware update between 3pm-3.30pm 🙂

Message 7 of 27

Around 3-5pm today would be a good time thanks and I will let you know if I seem to be back in business.

0 Likes

Message 8 of 27

Hi pixcellator

 

I can make a change to your firmware, when would be the best time to do this?

 

We advise to leave the router switched on without being rebooted whilst we update the firmware, this should take no longer than 15 minutes to update.

 

Thanks

0 Likes

pixcellator
Participant
Message 9 of 27

@Michelle-TalkTalk 

Could you please pickup my issue again? I am guessing only that my router firmware was updated in the last 3 weeks, perhaps you could confirm? If so could you please roll it back. If not, do I need a new router? 

 

Thanks

0 Likes

Message 10 of 27

Thanks ferguson, I had already gone through this or similar.

0 Likes

ferguson
Community Star
Message 11 of 27
0 Likes

Message 12 of 27

Yes, UPNP is enabled. Router is still at factory defaults and was more or less working, but dropped out today, just the same as last week.

0 Likes

ferguson
Community Star
Message 13 of 27

Have you got UPnP enabled on your TalkTalk router? 

0 Likes

Message 14 of 27

Yes, thats the gist of what I'm saying.  This is my Xbox connected to the 2nd broadband line from EE

20220511_210224.jpgand this is my Xbox connected to my broken TalkTalk afterwards.

20220511_210451.jpg

Both are within range of my Xbox, but the TalkTalk broadband is mine and it isn't working correctly for at least the last 2 weeks.

 

My money is still on a router firmware upgrade, but there is definitely a problem.

 

Thanks

0 Likes

ferguson
Community Star
Message 15 of 27

Why not try Open NAT on the Xbox?

0 Likes

Message 16 of 27

OK, I had a couple of days ok, although I noted lag in game that I didn't have before. This evening, Internet became haphazard and then stopped working. Again I could not get NAT on my Xbox and it read "NAT Type: Getting Info". Eventually rebooted the router and rest of devices came back online, but Xbox is back to square one although with NAT Type:Moderate, but still it isn't working. 

 

I think I've had enough and would like my router firmware rolled back please.

0 Likes

Message 17 of 27

Hi,

 

I'm sorry for the delay and thanks for the update.

 

Thanks

 

0 Likes

pixcellator
Participant
Message 18 of 27

OK, when I got back home today I tried to come at it fresh and start again. Worked through all the firewall rules one by one. I noticed that sometimes my changes were not taking, so I thought perhaps there is a configuration corruption after the firmware update and thats why it is misbehaving? So I decided to factory reset the router as a last stand and to my pleasant and tentative surprise my Xbox is back online. Hurray!

 

Of course I will have to restore some custom port forwards and so on, but at least it is working again.

I will risk the custom configuration later and monitor, but I think the thread can be closed after Monday.

 

It would be nice if you can confirm that the issue is caused by a firmware and if so posy a sticky thread or something so we have something more definitive to find.

 

Thanks

0 Likes

ferguson
Community Star
Message 19 of 27

Well it's worth a try, the support channels suggest as such. 

 

Is your broadband otherwise working OK apart from your Xbox devices? If so, it is unlikely to be a TalkTalk issue as such. 

Message 20 of 27

@ferguson 

// OK, is it still not working on your TalkTalk connection, while it is on your mobile hotspot? //

 

Correct it is still not working. I will try it again on both when I get home as I had also gone through giffgaff to lift restrictions on my mobile hotspot, but I'm not overly optimistic.

 

// Have you tried resetting the Xbox? //

 

If you mean factory reset no, I have shutdown and restarted it several times between changes. Also, the other factor is that both my Xbox S and Xbox 360 are the same and both were fine until last week.

 

Thanks

 

0 Likes