cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Incoming emails blocked

Reply
46 REPLIES 46
miket
Conversation Starter

For several months I have not been receiving webmails sent by a friend in the USA who is on cox.net. They do not appear in my inbox, or in trash or spam. But I can send to him at his cox address. Does this, as I have been told, mean that the problem is definitely at his end? Are there any other possibilities?

Gondola
Community Star

Hi @miket 

 

Does your friend get any bounceback error messages indicating why the email from him has not been delivered?

 

It's possible that the emails aren't authenticated if sent by an email client not directly connected to the Cox network and could be being blocked by network spam filters outwith the TalkTalk network or by the TalkTalk network spam filters.  But usually webmail is sent fully authenticated.

 

Has he tried using an alternative email address, say a gMail address, to see if that works?

 

If you could check your Community Profile Personal Information (Click here) includes your name, address, current TalkTalk landline 'phone number and an alternate number (mobile recommended). Add, then scroll down and add your email address and then your sender's email address in Private notes and then save changes. The TalkTalk Community Team OCE will then be able to see what can be done.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

I have updated my personal info as requested.

Re: your questions:

- My correspondent does not get any messages that his emails to me have not been delivered.

- His cox emails do come through to my hotmail address.

We have also found

- that his cox emails to my wife's talktalk address also do not come through (she is at the same postal address but uses different technology)

- His cox emails to others in the UK are received

- Resetting my router has not changed anything.

 

My correspondent has asked cox about it, who say that it is nothing to do with them.

I did not, by the way, get an email indicating your reply to my query.

Gondola
Community Star

Hi @miket 

 

It wouldn't be a surprise to find that there's a mailbox issue.  It's either full, corrupted or your own email address is being blocked by a filter rule, usually a Blocked Senders Filter Rule.  The Blocked Senders Filter Rule is carried over from the previous Webmail platform. Worth a check.

 

Sign in to TalkTalk Mail and:

  • Select the Menu option      top right
    (triple line hamburger icon)
  • Select Settings from the list
  • Select Mail (left side panel)
  • Select Filter Rules
  • Select Disable for all previous rules to troubleshoot
  • If the Blocked Sender's Filter rule is there
    Use the Edit option to check and edit an existing condition

If there aren't any filters set up in your mailbox then TalkTalk will need to raise a ticket for an investigation to see why both the Community notifications and the Cox emails aren't being received.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

Community Team

Hi miket, has Gondola got you sorted now or do you still need help?

miket
Conversation Starter

As suggested above I checked that there is nothing in the Blocked senders list, but @cox.net does appear under 'Allow'. Not sure that helps. Otherwise, I still have the problem.

Gondola
Community Star

Hi @miket 

 

As there isn't an "Allow" option in the Filter rules for TalkTalk Mail I have to assume you're looking somewhere else. But it's suspicious that Cox.net is quoted and Cox.net emails aren't being received.

 

Please take a screenshot of where you see the Allow Cox.net and after image editing to obscure any personally identifiable details would you post here using the Photos (Camera) icon above this Reply area. 

 

We'll try to help you fix the issue.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

ALlow pic_html_daeb5c7d23a67eb9.png

 Bit surprised about your comment that 'Allow' is not an option on the talktalk website since this IS what I am using. Two choices come up: 'Block' and Allow' Clicking on 'Edit' for 'Allow' brings up the above.

Thanks for your continuing help.

Gondola
Community Star

Hi miket 

 

"Allow" is just the name that you've given to the Filter rule. 

 

But the rule isn't going to work in the way you expect.

 

For the rule to work the subject line for the email would need to contain the word "messages" as would the sender's email address e.g. messages@cox.net. But as the sender's email address isn't 'exactly' @cox.net so the entire rule fails and the filter process would go on to look at subsequent rules.

 

The action is to 'keep' which doesn't really do anything purposeful unless subsequent actions include redirecting emails elsewhere without keeping a copy.

 

I guess I should ask what is set up in your "Block" rule before asking if there any other rules that have been set?  I would then ask what is it that you wish to achieve with the filter rules and I'll suggest how to achieve your objective with a screenshot of a Filter rule that you can copy.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

I have not entered any rules (although I probably did enter the 'allow' in an attempt to help with the cox problem - it didn't work of course). I have no requirement to block anything at this stage. All I wish to do is to sort out the problem in question, i.e of not receiving cox emails. Does that answer your questions?

By the way, I am still getting no email notification of your responses.

Gondola
Community Star

Hi miket 

 

OK, select:

  • Menu (triple line icon top right of the TalkTalk Mail header)
  • Settings from the drop down list
  • Mail (or Email) and Filter rules
  • Select the dustbin icon to the right of each filter rule
    Until no rules exist

TalkTalk doesn't block its own emails so you should receive notification emails From: no-reply@community-notifications.talktalk.co.uk into the email address you used to register the miket username with on Community.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

Done that. What next?

Gondola
Community Star

...Wait to see if you get Cox.net emails incoming to TalkTalk Mail.

 

Is the TalkTalk Mail account the one you used to register with Community? If so are you now getting Community notifications? Having checked, of course, that you haven't ticked 'Do not email me' in your Community profile email settings.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

Thank you. I will ask my cox friend to test it again.

I have always had the option to receive email messages ticked.

Gondola
Community Star

@miket wrote: ...I have always had the option to receive email messages ticked.

...umm... the Community email option if ticked is Do Not Email Me!

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

Sorry if I have made that mistake. I will check again. What confuses me is that the box above right to these messages I am typing -  'Email me when someone replies' - HAS been ticked.

 

Annoyingly I cannot yet check whether cox.net emails are coming through since my cox.net correspondent has gone on holiday for a few days. However I have to say that I do not understand how deleting the 'Blocked' emails file can have made any difference since nothing was blocked (or have I misunderstood this as well?) I am wondering whether an email' authentication' issue may be involved.

Gondola
Community Star

Hi miket 

 

It's possible that network level filtering is blocking cox.net emails and I've asked for that to be checked.

 

But it's usually a blocking at the mailbox level that happens so deleting or disabling all of your Filter rules will remove the potential for blocking at mailbox level. You said you had only two Filter rule options come up "Block" and "Allow". We haven't seen what you had in the "Block" option but the "Allow" wasn't doing anything.  If both of those rules are now deleted then that's ideal confirmation that your mailbox is open to receiving and keeping the Cox.net emails and the email admins need to look elsewhere for the no delivery issue. The Community notifications not being received could be a mailbox level filter issue but very unlikely to be a network level block.

 

As for the Community email notification options, when you post, the 'Email me when someone replies' is ticked by default so you have to untick it to stop notifications of replies to that post on a per post option. The per post option doesn't override the global option of tick for Do not email me in the Community profile settings. So, if the global option is unticked and you don't untick the per post option then you should get Community notifications of replies.

 

Do please let us know that Community notifications are working as expected. If they're still not then that needs investigating in parallel with the non receipt of Cox.net emails.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

Thanks. Very Helpful. I have unticked 'Do not email me' in Settings, and ticked 'email me when someone replies' above this message. Will let you know if it works.

Re: deleting the 'blocked' instruction file, regrettably I did not send you a screen shot of that, but it had no content - nothing was blocked.  Take your point though, best to be sure by deleting it. My assumption is that it will not have made any difference but, as I said, I cannot test that until my correspondent returns from holiday in a week or so.

Gondola
Community Star

Hi miket 

 

That's perfect. You should now receive Community email notifications to your Community registered email address.  And deleting or disabling the Filter rules is exactly spot on in the troubleshooting for non-receipt of emails.

 

Ady will be back next week to follow through if any emails are still not reaching your mailbox.

 Gondola - Community contributor

To appreciate my help . . . If I offered a solution Best Answer

miket
Conversation Starter

Am now getting your community emails. Thanks for your help.