cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

One PC slowing whole network down

Reply
22 REPLIES 22
jbuchanangb
Philosopher

Hi

 

I have three Windows 10 PCs and other things on my network. The PCs are all using USB wifi adapters to connect.

 

However when one particular PC is connected to the network, the whole network grinds to a standstill. I have tried two different network adapters, and the effect is the same with both.

 

I have checked for other wifi signals which might be conflicting, but there are only 2 very low powered signals to be seen and no channel conflicts.

 

I would welcome any suggestions to work out what is going on.

 

 

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

As you have tried a known good WiFi adapter from another PC, the next stage will involve taking a Wireshark trace on this PC.

 

I have attached my guide on taking & saving Wireshark traces. Once I have the trace, I will analyse it for you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

Hello again

 

I downloaded both the Wireshank instructions and the Wireshank software to USB stick, and took it to the offending computer. Installed the software with the wifi adapter disconnected. Rebooted the PC.

Installed the wifi adapter, ready to monitor the behaviour, and produce a trace file.

 

Now unable to replicate the fault! If it recurs I will come back here with news.

 

 

 

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

No probs, whenever.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

Hello again

 

Have managed to replicate the error condition, and attached Wireshark trace file.

 

As the PC was behaving well I gave it some work to do and kept an eye on it. I set it to download the Windows 10 Feature upgrade 1903, and it set off doing it with a download rate of about 10Mbps, which I consider acceptable considering its distance from the router. Then suddenly the rate dropped to less then 1Mbps and the other wifi users were locked out. (Loud shriek of complaint from said user!) I signed off the account, thereby stopping the download, and signed back on. The previously reported error condition then prevailed, so I use Wireshark to capture the situation.

 

I hope that some light can be shed on the matter.

 

The forum has spotted that the contents of the trace file does not match the file type, so I have put it here instead

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

Thanks, I have got the trace now. I have removed the link in your post to it, just in case, there is any personal information within the trace. I'll try & have a look at it later today or tomorrow.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

Hi @jbuchanangb 

 

I have had a quick look through the trace, there does not seem to be anything in it other than normal internet traffic. There is no massive time delay on any packets, but if you can let me know the date & time this happened, I can go to that area of the trace & look in more detail.

 

There are some malformed packets, but that is normally Wireshark being unable to decode the packet fully, perhaps due to some proprietary protocol implementation.

 

For the next stage, please can you open a command prompt on the offending PC & issue these commands one at a time, pressing enter after each one and wait for the response. Then copy and paste the output from each into your reply.

 

netsh wlan show drivers
netsh wlan show interface
netsh wlan show networks mode=bssid

 

None of these commands will reveal your Wi-Fi password, although other netsh commands will.

 

Please feel free to PM the results to me, but if you do, please include a link back to this thread, so as I can quickly find it again.

 

Note I will need to know the names of your wireless networks.

 

One other thought, but in the case of this PC killing all other devices, I can't really see it affecting anything. Have you disabled power management on the adapter, it could also be worthwhile doing that to the USB port/root hub etc it connects to.

Thanks.

 

PS I have now proved that you can zip a trace file up & attach the Zip OK to a post.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

The date/time for that trace was 15/7/19 around 22.30. The file was saved at 22.37.

 

I have an opportunity this evening to switch the offending PC on again, and take your next suggested courses of action.

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

Hi @jbuchanangb 

 

What I meant was not what date/time the trace was started (I can see that from within it and that it ran for just over 90 secs), but was the date/time that the problem started?

 

I need the trace to be started before the problem starts & not stopped until after the problem occurs. I am hoping to find what starts this problem happening. If it is only started once the problem is present, I won't see the trigger to it all. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

One other thing that comes to mind, does this PC upload stuff to OneDrive or Google Backup and Sync? I have certainly had issues with Google Backup and Sync hogging my bandwidth on this PC when it has loads of stuff to upload, that made general browsing incredibly slow. I set a cap on the amount of data per second I wanted it to use & all was fine.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

OK

 

I have done the netsh commands and the results are as follows:

 

Microsoft Windows [Version 10.0.17763.615]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\Users\John>netsh wlan show drivers

Interface name: Wi-Fi 3

    Driver                    : Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter
    Vendor                    : Realtek Semiconductor Corp.
    Provider                  : Realtek Semiconductor Corp.
    Date                      : 28/05/2019
    Version                   : 1030.38.328.2019
    INF file                  : oem4.inf
    Type                      : Native Wi-Fi Driver
    Radio types supported     : 802.11n 802.11g 802.11b 802.11ac 802.11n 802.11a
    FIPS 140-2 mode supported : Yes
    802.11w Management Frame Protection supported : Yes
    Hosted network supported  : No
    Authentication and cipher supported in infrastructure mode:
                                Open            None
                                WPA2-Personal   CCMP
                                Open            WEP-40bit
                                Open            WEP-104bit
                                Open            WEP
                                WPA-Enterprise  TKIP
                                WPA-Personal    TKIP
                                WPA2-Enterprise TKIP
                                WPA2-Personal   TKIP
                                WPA-Enterprise  CCMP
                                WPA-Personal    CCMP
                                WPA2-Enterprise CCMP
                                Vendor defined  TKIP
                                Vendor defined  CCMP
                                Vendor defined  Vendor defined
                                Vendor defined  Vendor defined
                                WPA2-Enterprise Vendor defined
                                WPA2-Enterprise Vendor defined
                                Vendor defined  Vendor defined
                                Vendor defined  Vendor defined
    Wireless Display Supported: No (Graphics Driver: No, Wi-Fi Driver: Yes)


C:\Users\John>
Microsoft Windows [Version 10.0.17763.615]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\Users\John>netsh wlan show interface

There is 1 interface on the system:

    Name                   : Wi-Fi 3
    Description            : Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter
    GUID                   : 137d1836-d7c9-4021-bb50-42cc2f4462a3
    Physical address       : 00:0f:00:66:f0:80
    State                  : connected
    SSID                   : buchanet
    BSSID                  : 4c:8b:ef:d5:4a:88
    Network type           : Infrastructure
    Radio type             : 802.11n
    Authentication         : WPA2-Personal
    Cipher                 : CCMP
    Connection mode        : Profile
    Channel                : 11
    Receive rate (Mbps)    : 13
    Transmit rate (Mbps)   : 13
    Signal                 : 48%
    Profile                : buchanet

    Hosted network status  : Not available


C:\Users\John>
Microsoft Windows [Version 10.0.17763.615]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\Users\John>netsh wlan show networks mode=bssid

Interface name : Wi-Fi 3
There are 1 networks currently visible.

SSID 1 : buchanet
    Network type            : Infrastructure
    Authentication          : WPA2-Personal
    Encryption              : CCMP
    BSSID 1                 : 4c:8b:ef:d5:4a:88
         Signal             : 46%
         Radio type         : 802.11n
         Channel            : 11
         Basic rates (Mbps) : 1 2 5.5 11
         Other rates (Mbps) : 6 9 12 18 24 36 48 54

 



The situation seems to occur as soon as the USB Wifi interface is connected to the wifi network. If the USB device is plugged in, but not connected to the LAN, then as you would expect there is no adverse effect on the other devices on LAN.

 

While was running the netsh commands the PC was frantically thrashing the wifi at speeds of well less then 1Mb, and no other device could get any sort of a look-in. It may not be of any help to you, but I did run another Wireshark trace while it was in that state. I have attached it just in case it would help.

 

I'll go back to it and see whether I can get any sort of trace which shows the symptoms before and after.

 

The affected PC is my spare PC. It really doesn't do anything much at all. It's there for my grandchildren when they visit, but in its current state it can't even browse CBeebies!

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
jbuchanangb
Philosopher

To get the attached trace, I opened Wireshark, selected "Wi Fi 3", and then clicked connect to connect the USB WiFI adapter to the network. After a suitable duration, during which the WiFi limpralong at well under 1Mb, I hit disconnect and the tracing stopped. Does this get us any further forward?

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

Hi @jbuchanangb 

 

I have downloaded both of those traces, I think trace 3 is the most likely one. I won't have time to analyse it though until tomorrow PM.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

KeithFrench
Community Star

From a very quick look at trace 3 so far, the largest TCP conversation originated by your PC via an HTTP session to 205.185.216.42 which is an MS Filestreaming site at 19:54:46.306570000 yesterday (http://tlu.dl.delivery.mp.microsoft.com/filestreamingservice). It is requesting a list of files from this MS streaming server.

 

Do you recognise this - is it OneDrive? It does not transfer a massive amount of data though (815K), so unlikely to be swamping anything.

 

What is interesting is that the IP Segmentation goes haywire at 19:55:29.650959 for some massive amount of time (23.5 seconds) with numerous out of order packets & TCP retransmissions etc. This may though be a symptom of something else causing the problem.

 

I now need to focus on this time period some more.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

The PC has made a start at downloading Windows 10 Feature Update 1903, and when the speed ground to a standstill it had achieved about 75% downloaded. I expect everytime it sees an Internet connection it tries to resume that activity. I think I have OneDrive turned off, but I can check. I can also attempt to turn off the MS Update process. I can do this with wifi disconnected, and then trace the action of turning it on again.

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

Hi John,

 

No, don't worry about stopping anything running for now. I have just sent you a PM with the next stage of the diagnosis plan.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

Per my PM reply, I have now swapped out the HG533 and connected the DSL-3782, and the offending PC is ticking away nicely at 20Mbps. Problem is that means my main PC, is now getting slower connection, due to being further from the router. I will monitor the situation.

 

(Indications are some sort of confusion between the Realtek wi-fi dongle and the HG533)

 

I have another permutation which I could try, which is to plug the DSL-3782 into a phone socket near the TV and Youview box, but as there is a bridge tap fault reported on my internal wiring (so I have the router connected to the test socket at the master), this may present its own problems!

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
jbuchanangb
Philosopher

As an interim I have replaced the faceplate on the master socket, and connected the DSL-3782 into the master socket. This has also activated the house's internal telephone wiring with the bridge tap fault. Consequently it is now sychronised at 7890 upload and 27296 download whereas when connected to the test socket it was much closer to 10/40. I will monitor it for a while, and see if the connection is stable.

 

I still don't understand the conflict between the Realtek USB Dongle and the HG533 router, as I have two identical such dongles, and the other one was working just fine with the HG533 on a different PC.

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router
KeithFrench
Community Star

To answer the conflict question, I need to find the cause of the problem. The last Wirehark trace showed when it happened & what effect it had on the particular HTTP session, but it did not give the cause of the problem. This is most likely that without expensive dedicated additional hardware, Wireshark cannot record the wireless control frames.

 

That is why I suggested combining a Wireshark trace with a Netsh trace, but whilst I am happy to do this, it will be very time consuming & hence a number of days before I could find the cause.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

jbuchanangb
Philosopher

I notice that the date on the Realtek Driver was 28/5/2019. That is very recent, and may be a factor. I will look at the date on the driver in the PC which wasn't having a problem.

 

I only started using the HG533 at Easter, but it was brand new out of the box, as I had been storing it for a few years.

 

If I can find a tolerable working solution, using some combination of router, PLAs and USB interfaces, I will file the problem as one of life's great mysteries. After 40 years of working in IT, I know sometimes a workaround is better than a solution.

surfing from my 10 years old Dell Inspiron 545, running Windows 10 and using a Realtek RTL8811AU Wireless LAN USB Network Adapter to connect to Sagemcom FAST 5364 router