FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Please switch the Wi-Fi optimisation software off on my new router

mk123
Team Player
Message 20 of 20

Hello

 

 

In November 2020, I was having problems with my new TalkTalk wireless connection (low speeds and poor stability). I asked you to switch the Wi-Fi optimisation off on my router. This fixed the problem. See https://community.talktalk.co.uk/t5/Fibre/Frequent-disconnections-with-Sagemcom-TalkTalk-Wi-Fi-hub/m...

 

However, I am now having a different problem where the router will, at random times on average once every few days, stop allowing new connections (so, for example, if I am in a session working from home, it'll be fine, but then if I try and disconnect and join from another device - a new session - I will see that this problem has occurred, and it won't allow me back on with either device).  Meanwhile, the router will be working for other devices which have been in a session since before the error occurred. The only fix when this error happens is a router restart (which always works). However, restarting the router is very disruptive if everybody is working from home. The error message is a generic Wi-Fi error where Chrome can't reach the internet - it varies, such as the computer being actually disconnected from the router, or connected but with no internet, or the connection is fine and shows internet connectivity but there's a DNS/IP error when we try and do anything.

 

I think the easiest way to try and fix this is to try my other FAST 5364-3.T8 router, which I've now connected. I would prefer to try this rather than something more involved, unless this fails. Can you please check that the Wi-Fi optimisation is also switched off on this new router, and if it isn't, switch it off, so that the old problems don't come back too? Please inform me when this is done so that I can change the Wi-Fi channel settings back that the optimisation software will have overridden. 

 

Thank you 

0 Likes
19 REPLIES 19

Message 1 of 20

Hi mk123

 

The WIFI optimisation has already been switched off and is still showing off.

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 2 of 20

Hi @mk123,

 

The new firmware has not yet been rolled out, if you go to the login screen for your router you will likely see at the bottom that it is still on firmware version SG4K10002816t, this is the 'current' firmware that does have the DNS bug.

 

Not sure what would have caused your Wi-Fi Optimisation to be switched back on, it you have factory reset your router (or if it has been reset remotely) then this may have switched it back on.

 

Unfortunately the staff won't be back now until Monday, but they should be able to switch this off again for you on Monday.

mk123
Team Player
Message 3 of 20

Hi. My speed has been slow all week, and I noticed it's because my Wi-Fi channel got changed to 44 again (I changed it back to 60 and the speed recovered from 1Mbps to 40Mbps). This means the optimisation must be on again. Is this because the firmware update has rolled out? If so, @Skynet_TX @demulv is the DNS workaround no longer needed and I should change it back? It hasn't reset the workaround DNS settings. And @Debbie-TalkTalk please can you make sure the optimisation is switched off on the router I am currently using, and won't be switched back on again. Sorry, I made another thread an hour ago https://community.talktalk.co.uk/t5/Fibre/PLEASE-SWITCH-THE-WI-FI-OPTIMISATION-SOFTWARE-OFF-ON-MY-RO... as I would really like this fixed before the weekend. I just don't understand why customers can't control the optimisation (if we can even call it that) setting ourselves, and that the channel selection setting is a farce (what does it mean to have an "AUTO" setting when any option you choose is going to get AUTO-overwritten anyway??) Thanks

0 Likes

Debbie-TalkTalk
Support Team
Message 4 of 20

Hi mk123

 

How has the connection been since the WIFI optimisation was switched off?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 5 of 20

@demulv I expect there is a decent chance that when the new firmware installs it may well reset that setting anyway, but I agree that once on the new firmware it would make sense to go back to the factory DNS settings.

 

I don't know how much caching of DNS the Sagemcom does, but I've certainly seen no noticeable performance impact of making the change, and as the alternative was having a router that sometimes didn't resolve DNS requests at all then I'm happy with this workaround until the new firmware is released !.

0 Likes

Message 6 of 20

It will slow down the connection slightly, as when using the router for querying DNS requests, if it has to query TalkTalk's servers it then 'remembers' it.  So any subsequently queries for the same request (or website) can be handled directly by the router.

 

By telling clients to directly contact TalkTalk's servers every time, you're not able to take advantage of the router being able to save that trip.

 

That said though, if it makes your service more reliable, then I'd suggest it's worth the minor speed hit...  although you might want to switch the DNS setting back to 192.168.1.1 after the firmware update.

0 Likes

Message 7 of 20

Hi mk123

 

Thank you. The WIFI optimisation has now been switched off.

 

Debbie

Skynet_TX
Community Star
Message 8 of 20

Yep, that will do nicely 🙂

 

Note to Community Staff (to save them reading all of this thread !) : Please can you disable Wi-Fi Optimisation for @mk123, thanks.

Message 9 of 20

I restarted the router. That should do it, right?

Skynet_TX
Community Star
Message 10 of 20

Just ensure you have made your devices disconnect and reconnect to the router since making the change, as your devices will only pick up that setting at the point they make a connection to the router.

Message 11 of 20

Thanks for all your help. I have given the DNS setting a try. And yes, it is on the newest firmware. I'll just wait for TT to turn off the optimisation now - it keeps changing the channel and slowing my speeds.

Skynet_TX
Community Star
Message 12 of 20

Hi @mk123,

 

If your router currently has its default settings then you are already using the TalkTalk DNS servers, however your router will currently be acting as a 'man in the middle', so your devices use your router as a 'DNS Server', but your router then just passes the request on to the real TalkTalk DNS servers. By making the change I've mentioned you are just telling your devices to go direct to the TalkTalk DNS servers and not use the router as a 'man in the middle'.

 

The screen shown above in your screenshot is the correct screen to change.

 

If this is your 'new' Sagemcom then can you check to ensure it has auto updated to the current version of firmware, the firmware version is shown on the login screen for the router, and the current version is SG4K10002816t.

mk123
Team Player
Message 13 of 20

A few more things. TalkTalk: I now know my current router does in fact have the optimisation enabled (it changed my channel) so please switch it off. @Skynet_TX, the instructions on the page you linked don't exactly match the screens I can see. They might be outdated. So is the below the right place to change the DNS settings or the second, wrong one you mentioned? Thanks again

mk123_0-1625398302056.png

 

0 Likes

Message 14 of 20

Thanks @Skynet_TX. Are there any known issues/side effects that may arise doing that fix? Does it slow down the connection to have to use TT DNS servers, for example?

0 Likes

Skynet_TX
Community Star
Message 15 of 20

Potential workaround :

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work).

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.

mk123
Team Player
Message 16 of 20

Thanks again @Skynet_TX. I am very comfortable logging in and changing settings; if you have a link to a workaround for the DNS error, I'd be grateful for them and will take a look. I would like as many options as are available, and hopefully one of them will work. I just want a stable connection that's fast enough to do the things I need it to.

Skynet_TX
Community Star
Message 17 of 20

Staff should be able to reply early next week, and may well be able to send you a Huawei hub (and a returns bag to send back the Sagemcom).

 

There are some settings you can change in the Sagemcom that can potentially work around this problem, but that is only really an option if you are comfortable with logging into the router and changing settings, many people don't really want to do that, so if you don't want to do that then a replacement Huawei is the easiest 'fix'.

mk123
Team Player
Message 18 of 20

Thanks @Skynet_TX for your help. Randomly-occurring DNS errors does match my issue, and I am using a Sagemcom router, so in that case I would like to request a Huawei router to try; it sounds likely that I will run into this issue again with my second Sagemcom router (which arrived for some reason when I requested a Huawei router to try during my previous issues). I really need to fix this issue as soon as possible because it is disrupting my household's working from home, so don't want to sit and wait to see if it happens with the second, identical Sagemcom.

Skynet_TX
Community Star
Message 19 of 20

Hi @mk123,

 

There is a known issue with the current version of firmware for the Sagemcom that can cause the DNS service to randomly stop working in the router. The symptoms that you describe are a bit unusual, and don't follow the most common pattern that people tend to see when they have this problem, but it is still possible that this may be what is causing the problems for you.

 

TalkTalk are currently testing a new version of firmware that will fix the DNS issue, so if it is that issue that is causing your problems then the new firmware will likely fix it. There is no confirmed date for this firmware to be released, but if all testing goes well it may be later this month.

 

If the staff here did think the known DNS issue was the likely culprit then the other solution would be for them to send you a router of a different type (the Huawei hub, as this is not affected by the DNS issue).

 

The staff here won't be around now until Monday, but they should be able to respond to this post early next week to help.