Showing results for 
Show  only  | Search instead for 
Did you mean: 

TV Support

For help with your TalkTalk TV box, channels and apps.


First Timer
Private Message
Message 3 of 3

As daft as this may seem, my YouView refuses to record ITV3!i have completed  factory resets, ensured software is up to date, there is  95% free disk space. The signal strength is ‘excellent’.  There are two episodes of a soap my wife likes to watch each day. The first episode Fails to record, the second episode records fine. This doesn’t make any sense. I haven’t tried a full reset delete recordings yet . Any words of wisdom?


Support Team
Private Message
Message 1 of 3

Hi Shimganar,


Excellent advice from fr8ys, try ITV3+1 and let us all know if this works for you 🙂



Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips

Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.

Community Star
Private Message TalkTalk
Message 2 of 3

This is a known issue with channels that are on mux 3 & 4 and has been causing issues primarily with C4 and Film4, but does affect others as you have found.


YouView are investigating with the Mux owners as it appears it may be an issue with them rather than the box.


A TalkTalk customer has been helping YouView to narrow the issue and there is a thread on the  YouView forum regarding this.


Unfortunately it's a wait for a solution to be found and implemented.


However ITV3+1 is on a different mux so it might be worth trying to record via this channel rather than the main ITV3 channel.


If it works, please let us know.


Good luck.

Please remember to mark Solved Posts with Best Answer. Doing so helps other customers and saves TalkTalk's Support Team time by only looking at unsolved topics. Thanks, Steve (a fellow customer).