Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wifi Hub Router | 2.4 devices not able to connect.

Waqar_Sher
Chatterbox
Message 11 of 11

Hi TT Team, my 2.4g devices connected to wifihub are not able to access internet out of no blue. 5g is working perfectly fine though. So far I have tried following

 

1- Splitting bands and changing names (different for 2.4 and 5g) - No luck

2- Reseting the router - After resetting, 2.4 g devices worked briefly for sometime and then again internet died out. My mac is not even able to connect to 2.4 band. 

 

Can you please help ? some of devices only support 2.4 

 

Thanks

0 Likes
10 REPLIES 10

Message 1 of 11

Hi Waqar_Sher

 

That's great, thanks for letting us know 🙂

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 2 of 11

Hi @Waqar_Sher,

 

Yep, if the new router has resolved the issues then you can just return the old router in the returns bag that (hopefully) came with your new router.

 

Remember to keep proof of postage when you return it, just in case TalkTalk don't record the return correctly (it happens more often than it should !).

Message 3 of 11

Hi Debbie, Thank you for sending replacement router, I have tested with it and both bands are working perfectly fine now. I can see improvement in speed as well. I will pack old router, its charger, cable and extension (from new one) and drop it to nearest post office within this week. Please let me know if it's fine with you. 

 

Thanks

Message 4 of 11

Message 5 of 11

Thank you very much Debbie - Appreciate the prompt response. Will update here once router received and tested. 

Message 6 of 11

Hi Waqar_Sher

 

Thanks for your reply.

 

The router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

I have also sent you a Private Message with a link to a short survey.

 

Thanks again.

 

Debbie

Message 7 of 11

Hi Debbie - Good day!!! As I have tried all available tips and tricks, can you please send the replacement router ? as few of my devices support 2.4 g and are offline. Thank you. 

Message 8 of 11

Hi Waqar_Sher

 

I'm sorry to hear this.

 

Would you like me to send a replacement router for testing to see how the connection compares?

 

Thanks

Waqar_Sher
Chatterbox
Message 9 of 11

Hi Skynet_TX - Thank you for prompt response, Yes I checked with different channels, and did run a channel health test, results are same with different channels I have tried. 

Skynet_TX
Community Star
Message 10 of 11

Hi @Waqar_Sher,

 

Have you tried changing the channel used for your 2.4GHz band, you can use free smartphone Apps like this to see what channels are being used within range of your smartphone, you can then change your router to use channels that are less congested.

 

If trying the above makes no difference then it may indicate an issue with the router, the Support Team here would be able to help with that when they return tomorrow.