cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FIbre Support

Get expert support with your Fibre connection.

Can't host multiplayer servers with fibre and new router/hub

witor
Participant
Private Message
Message 19 of 19

before I got the new optic fibre connected and the new router/hub I was able to host servers for a multiplier game. Now with the new connection and the new hub, after starting a server people who want to connect to it get a message 'host not found'

 

I have already tried to switch the router firewall off and also tried to set up some UDP and TCP port forwarding for port 56278 which is the port that my server uses, but nothing worked so far...

 

being able to host these servers is very important to me. Any ideas what I could try?

 

 

0 Likes
18 REPLIES 18

KeithFrench
Community Star
Private Message TalkTalk
Message 1 of 19

 

You're very welcome @Debbie-TalkTalk 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 2 of 19

Thanks for your help @KeithFrench 

 

@witor I'm glad to hear that this is now working ok 🙂

KeithFrench
Community Star
Private Message TalkTalk
Message 3 of 19

Well it had to be the firewall or your application, it was never the router or TT network. Glad it is all sorted now.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 4 of 19

Keith thank you very much for your effort, time and willingness to help me. 

 

I think I have solved the problem by setting Windows Defender like this:

WindowsWindows

I don't know why condor and condor dedicated appear on the list multiple times (maybe because I have a few versions of them on the HD), but I don't care as long as everything works. It is weird that with my previous settings where condor was allowed on one type of network but not the other everything worked, but with the new router it stopped working. But I am glad that it is fixed now and everything seems to work the way I wanted.

 

Once again many thanks for your help!

KeithFrench
Community Star
Private Message TalkTalk
Message 5 of 19

The next diagnostic step then is Wireshark. If you can get me a trace from it when the server that is not working, I can analyse it for you. A warning that this is not for the feint hearted, do you want me to send you a guide on using it to get me the trace?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 6 of 19

I tried again this time I just used netstat -a  command in the windows command prompt

This time it gave me a long list of connections some starting with TCP and some with UDP.

 

In both cases; when I started a multiplayer server from within the game and second time when I started the dedicated server app after running netstat -a on the list I could see these two lines:

UDP    192.168.1.12:56278     *:*

UDP    [fe80::5c3e:c0cc:27ad:dd86%10]:56278  *:*

 

Note that 56278 is the port that the server is supposed to be using. 

 

These two lines were not present when I tried netstat -a with the server not running.

 

When the server was running in both cases (game and dedicated server) there was no reference to TCP and 56278 after running netstat -a

 

Hope this shines some new light...

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 7 of 19

That is the problem then, your game is not opening TCP port 56278 at all. There is a route for this port through the router, as it works in the other mode of operation. It is the responsibility of an application (not the router) to open the port, without it doing this it will never work. This is a networking fact, nothing to do with TalkTalk at all. I know that you said it worked before your upgrade, but perhaps there was also an update to the game.

 

As I said in my previous post though, if this game mode that doesn't work, it is using UDP port 56278, then that changes everything & a different method of diagnosis will be required. Please can you confirm with the game manufacturer whether it is using TCP or UDP at this point?

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 8 of 19

I figured out (google) that TAP is related to the VPN I use to access my work network. 

 

I am sure you can tell I am not a networking wizard. I have no idea what the difference between TCP and UDP is, so I don't know which one Condor dedicated server uses.

 

After running netstat -a | find "56278" in the command prompt I get nothing...

 

NothingNothing

 

Someone on another forum suggested that I might be behind  CGNAT (whatever that means) and that could be causing problems. Is TalkTalk using CGNAT?

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 9 of 19

By the way a TAP adapter like the one you said you didn't know what it was, these are normally VPN clients.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 10 of 19

Well, you have redacted some important information, but not to worry. In future please PM them to me for your privacy. I will also delete the screenshot you included from your post.

 

OK to the bit that does not work:-

 

"Condor also has a dedicated multiplayer server app that allows you to start the server without actually running the game."

 

I am guessing here that this is still TCP port 56278 & not the UDP one.

 

When you get to this part, please issue this command prompt command:-

 

netstat -a | find "56278"

 

Then PM the screenshots to me.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

witor
Participant
Private Message
Private Message

Message 11 of 19

Windows 10

 

I just checked IP settings because some people elsewhere suggested that the dedicated server app might get confused if different protocols are allowed on my machine. I am not sure if I understand what they meant, but I include a screenshot just in case it is of any value. I am not sure what is the 'Unknown adapter Local Area Connection'

 

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 12 of 19

What operating system is this game running on?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 13 of 19

I have put the firewall back to medium and I have replaced UDP and TCP forwarding with just one UDP-TCP. with no effect.

 

I do not try to connect and I am not connected to my own game server from my local machine. 

 

The game I want to use (Condor Soaring Simulator 2) has 2 ways of setting up a multiplayer server. One is from within the game, and If I start the server from the game everything works and people can connect to my server.

 

Condor also has a dedicated multiplayer server app that allows you to start the server without actually running the game. Before I got my new optic fibre connection and new router/hub I had no problems running this dedicated server app and people could connect to my server.  Now with the new hub I can host from the game, but not from the dedicated app despite the fact that all settings and port is set to be the same on both! My problems started after I got the new connection and hub.

0 Likes

Message 14 of 19

Hi witor,

 

How are you getting on, has Keith's advice helped?

Chris

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 15 of 19

OK, put the firewall back to medium, there is no need to change that at all. I have just tried this on my 5464 & the TCP port reported as open on my first attempt. Have you tried a port-checking website for that? I used one PF rule & just set the protocol to TCP-UDP, which saves needing two separate rules.

 

Are you trying to test from a device connected to your router, out to the router's WAN IP address & back in again? If so you will fall foul of NAT Loopback and the port will be dropped coming back in. If doing this, specify the game server's private IP address, not the Public one.

 

If you want to test using the WAN IP, use a smartphone, drop the Wi-Fi connection to the router & use mobile data instead.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 16 of 19

As additional info this is a screenshot from the game server I try to use (and which worked just fine before new connection and hub) and the message I get when I try to test if my server is accessible for other players.

Image 004.pngImage 005.png

 

 

0 Likes

Message 17 of 19

I have FAST 5464-1. T4

Image 001.pngImage 002.pngImage 003.png

 

 

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 18 of 19

What make & model of router do you have now? Please include screenshots of your PF rule in it. I assume that you are getting them to connect to the new WAN IP address, not the one that the old router had?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes