FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Port Forwarding on Sagemcom 5364

beardieginge
Chatterbox
Message 18 of 18

Hi all,

 

I've been trying to port forward to allow connections to a server running on my desktop. I have done the configuration via TalkTalk hub correctly, I have made the IP address static on the desktop where the server is located, I have obtained and tested the right public IP and allowed all the relevant rules on my firewall to allow the port to listen to external connections but Port checkers report the port is still closed. I have gotten friends to test the server connection using the right public IP from their machines but they are not able to connect.

 

I was wondering if maybe the fact I have a Huawei G Fast Modem that this might be causing the problem and if so, how can I remedy this? So the internet comes in via fibre connection to the master socket, from master socket to the modem and then to my Sagemcom router.

 

(I hope this makes sense, networking isn't my strongest point)

 

thanks for any advice in advance

 

0 Likes
17 REPLIES 17

Message 1 of 18

Hi beardieginge,

 

Glad to hear that you've manged to get this sorted 🙂

Chris

0 Likes

Message 2 of 18

Great stuff @beardieginge, glad to have helped.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 3 of 18

Hi @Piethorne 

 

I think it differs between Minecraft run on a Windows PC, or when Minecraft is used on other consoles etc. I too may not be 100% on this, but this has been the only port required to be forwarded to a PC, so other customers that I have helped in the past have told me.

 

So far I am still trying to test TCP port 25565 to see if it is open on @beardieginge PC & from a port checking site. 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 4 of 18

@Piethorne @KeithFrench 

sorry for the delay Keith, I just tried Piethorne's steps and whilst this had been done already, it made me realize that I had somehow added block Domain and Public firewall rules for Inbound and Outbound for the application. I removed these, port responds open and friends can now connect!

 

Thanks for your help all!

Message 5 of 18

I may be wrong but I think a few more firewall rules needed to be added. According to https://www.instructables.com/Add-MC-Server-to-FireWall/ the program has to be allowed to run through the firewall as well as inbound and outbound rules.

 

I don't run a minecraft server myself so can't say for certain.

I'm just a customer who might be able to help, not official help & support.

Message 6 of 18

Yes, thank you that does at least allow me to check everything. From what I can remember on a PC, Minecraft only uses TCP port 25565, not UDP. However, this extra rule will not stop it from working.

 

To confirm the status of things now, before going down the Wireshark route, please can you go to this testing site from a PC or other device connected locally to your router, with Minecraft server running & TCP port 25565 open:-

 

https://portchecker.co/ 

 

Put in this port & tell me the result when you click the Check button?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 7 of 18

Hi @KeithFrench ,

 

Is this what you're after?

 

beardieginge_1-1621679360059.png

 

If it helps, these are the settings I set for both the UDP and TCP firewall rules

- Action: Allow the connection

- Enabled

- Profiles: Ticked Domain Private and Public

- Edge traversal: Block edge traversal

- Scope: Any IP Addresses

 

This was essentially the same for the outbound rules as well.

0 Likes

Message 8 of 18

Hi @beardieginge 

 

The more I look at the screenshots of your firewall rules they do not give me much idea as to what you have setup, other than the ports.

 

I am assuming that these are inbound rules plus I cannot tell what profiles you have allowed.

 

A far better screenshot that I would like to see, is to go back into Windows Defender Firewall with Advanced Security and then expand the Inbound Rules section & click on your rule in the Inbound Rules pane. You may have to resize this to show everything before getting me a screenshot of it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 9 of 18

Hi @beardieginge 

 

I am not sure as it has been some time since I used the Windows Firewall, but you have rules where the remote port is set to 25565. You do not want them as it is only the local port that will be 25565. Try deleting those rules. Other than that it will need to be a Wireshark trace as I mentioned in my previous post.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 10 of 18

Providing that you have not changed anything else in the router, it will be fine.

 

The next thing to do is to prove where the problem is. I need you to get me a Wireshark trace, I can provide full details on how to do this.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 11 of 18

So I've loaded the server and now get the correct response, however friends are still not able to connect via my public IP, could this be to do with the Modem/Router set up?

 

beardieginge_0-1621609476730.png

 

0 Likes

Message 12 of 18

Hi @beardieginge 

 

Thanks for confirming about the firewall, it is just I look to the inbound rules in Advanced Security rather than the screenshots you sent. However, the firewall is probably not the problem.

 

The fact that you did not get a response to the netstat command, shows that the TCP port 25565 is not open on the PC. It is always the responsibility of the application (Minecraft in this case) to open the port. When the port is not open on the PC, any port checking will always fail.

 

Please can you find out why your Minecraft is not opening this port?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 13 of 18

Forgive me if I'm missing something, I've ran the command but do not get a response

 

beardieginge_0-1621606522986.png

 

"They look OK, but the normal way to open ports on the Windows firewall is via:-

 

Windows Firewall with Advanced Security"

 

This is how I originally set them up.

 

@KeithFrench 

0 Likes

Message 14 of 18

They look OK, but the normal way to open ports on the Windows firewall is via:-

 

Windows Firewall with Advanced Security

 

Please can you open a command prompt on this PC & issue this command:-

 

netstat -a | find "25565"

 

Thanks.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 15 of 18

Sure, no problem. I hope these help

 

beardieginge_0-1621540641911.pngbeardieginge_1-1621540650697.png

 

0 Likes

Message 16 of 18

Hi @beardieginge 

 

@Michelle-TalkTalk has asked me to help you. It won't be anything to do with the modem. What TCP or UDP port(s) are you trying to forward? Please can you provide me with a screenshot of the port forwarding in the hub, so as I can check it, I know you said it was OK, but if I am to help you, I need to start proving what is correct. To save asking in another post, please can you also include screenshots of your firewall rule as well.

 

If you prefer you can PM all of these to me.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Michelle-TalkTalk
Support Team
Message 17 of 18

Hello,

 

@KeithFrench - Would you be able to offer any advice?

 

Thanks