Showing results for 
Show  only  | Search instead for 
Did you mean: 


We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

No choice but to cancel FTTP -Eero is appalling device

Popular Poster
Private Message
Message 9 of 9



Apparently with FTTP 900Mbs and VOIP it is not possible to use a 3rd party router (one that can use OpenVPN, has USB sockets, 1Gbs or greater Ethernet) with VOIP - it is Eero or nothing.

So I choose nothing. Cancelling my new contract after less than 2 days.


Shame because the speeds are good.




I got the FTTP installed on Monday by Openreach engineer.

There was some issue with the remote call centre - it took them over a day to enable the ONT - apparently there is a lack of training on newer device.

At that point I figured "oh well that's OpenReach support" - the engineers are great.


Next day the service came up.

Then the fun started.

That Eero app is so limiting.

I cannot use a normal web interface to interact with it.

I cannot connect to it without a mobile phone.

Darned hard to read screen on a Samsung S10e. I see suggestion to use DeX mode - good idea.

Thing is my phone ran out of charge - so I cannot continue to setup the network.

What if I lose my phone?

OK I can create a slave admin on another device - except that didnt work for me - perhaps I needed to wait for other phone to charge.


So I enquired with TalkTalk - what compatible routers are there? 3rd Party.

What spec am I looking for - I see some VLAN 0 requirement but with my existing Simply Broadband I suffered that poor 633 Super Router. Once I replaced with Archer 2800 I finally got the wireless and features I wanted.


Apparently ONLY Eero can work their gear.

I dont believe it. My friend has Vodafone. He also didnt like their router. He plugged Asus in. No problem.


I have the full transcript - Peter said it is Eero or nothing.

Then I had no choice but to cancel - after many years of using Tiscali / Talk Talk I am off.


The Eero app just doesnt work for me. The mesh boxes dont have the features I need. Such a shame.


Posting on the off chance that someone will say "Oh I just bought the Asus XYZ and it has OpenVPN, USB ports,. 1GB or 2.5GB ethernet ... web based UI and just works with my FTTP".

The VOIP is a box that plugs into Ethernet. Nothing special that Eero does -it is a mesh thing. I am happy to do without that.


thanks for reading if you got this far. Soon to be ex TalkTalk customer.




Message 1 of 9

Hi Steve,

Glad to hear you got it sorted. We may be able to get the cease cancelled, if you'd like us to do this can you please update your community profile to include your:


  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated.



Message 2 of 9

Hi Chris


I think I solved it myself but I also need to acknowledge Debbie's help and whomever wrote the post about Fibre,


Now I need to be able to discuss with someone (please not a forum chat nor a bot) - how to uncancel the cancel of the fibre please.

It is odd that the core backend support team dont really know your tech - but forum based support do.



If you think anyone is interested in how I got it working please let me know where to post (pretty much what Debbie linked except DONT set the VLANID)

Might be interesting to some "user confirmed external routers".

Here I can use my router to do what I need without that blasted Eero UI.

And the VOIP phone just plugs into one of the 1000Mbs ethernet ports on my Archer 2800 and works.


Best regards

Message 3 of 9

Hi shooking_sybase,


I'm just trying to get some clarification about this, I'll let you know when I have an update


Message 4 of 9

Just wait for staff to get to your thread.


The point is that every extra post pushes these threads back in the workflow. 


If you just keep posting, @shooking_sybase, it won't reach staff, and for other people, it delays progress to staff support too if you keep posting on their unresolved threads.

Gliwmaeden2, a fellow customer.

Message 5 of 9

You are probably right.

And this stops anyone commenting on whether a non Eero router can be used on FTTP with VOIP because??


And I just checked. VOIP Ethernet box plugged directly into ONT, Eero switch off. Works. Who knew.

So I call the official tec support info as wrong.


I would simply like to use a suitable 3rd part router on FTTP rather than the Eero.


The VOIP is a red herring.

What settings do I need from TT

And any unique constraints on an ethernet supplied to wireless router.


Message 6 of 9

Nothing shows us that you've completed the forum profile, @shooking_sybase.


You need to go via your avatar/name; settings. Add the order number / account number where it asks for landline number in Personal Information. SAVE CHANGES. 

Gliwmaeden2, a fellow customer.

Popular Poster
Private Message
Message 7 of 9

Hi @Gliwmaeden2 

I did. Peter from support and then the cancellation team (I have the transcript) explained  "you have VOIP package with FTTP, so it is Eero or nothing".

So I choose nothing - adios.


Since then I tried my router directly to the ONT.

In the manufactures instructions ( I need PPoE, Username Password.

I dont have these and I was rather hoping support could give me the details, I can confirm my Archer works, then calm down and look for a better WiFi 6 1GB modem - like an Asus Zen Wifi Xt8 - £210 with Amazon discount ending probably before I can get sensible tech support.


This morning I also confirmed I can simply plug a Windows laptop directly via Ethernet into the ONT and bingo. IP address and can surf the web.


I guess I should go ONT -- Unmanaged Switch --[PC, Ethernet VOIP]

If it rings when I call ... then please ask your support to stop insisting about Ethernet based VOIP only supported via Eero.


I also see Debbie has responded to similar request for 3rd party router -


And this is what I expecting from support - I hadnt found Debbie's post until this morning.

I replied to that thread - is this for FTTC or can it also work for FTTP?


Because if it can then I could

  configure my Archer as a test

  if successful, spec out a better router

  cancel the cancel

  stay with TT


but as it stands I have requested cancellation (your contracts dept didnt think I had FTTP/VOIP - where did I get the Eeros from!).

And I will be off to Vodafone. More expensive for similar service BUT their supplied router has a normal web interface, allowed DDNS, openVPN, has a USB socker for Samba mount etc etc


If your team can say "no this is a massive misunderstand - of course you can plug own router in - it needs to be this spec, some users like >>brand>>" then I can test this out and revert to being a happy TT customer.


Odd that more sense comes from the forum than the official support


Community Star
Private Message TalkTalk
Message 8 of 9

If you need support, please complete your community forum profile details for TT staff to identify your account.


It's appreciated if you could just stick with this thread. Don't post comments on other people's threads while they still need support for their issue.

Gliwmaeden2, a fellow customer.