Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't connect some Amazon devices - error "incorrect password" for the wifi

Darwinc
First Timer
Message 5 of 5

Hi,

 

I really hope someone can help.  I'm new to TalkTalk - only had the new line 5 days.  First issue: I have been able to connect some smart devices but others are failing to connect with an error saying incorrect password.  In the Alexa app it stores the password and is working fine to connect some devices but not others.   They all worked fine on Sky with no issues.  Any ideas what I can do?

Secondly: Where on earth is the help section to contact TalkTalk directly as I need to get this fixed ASAP or go back to Sky before I get charged an exit fee!

 

Thanks for your help

Claire Darwin
0 Likes
4 REPLIES 4

Message 1 of 5
0 Likes

Skynet_TX
Community Star
Message 2 of 5

It is also possible that Wi-Fi interference can cause 'wrong password' errors, so if you can identify if it is the 2.4GHz or 5GHz connections that are having issues then it might be worth trying changing the channel that your router broadcasts the Wi-Fi signal for that band on, you can use free smartphone Apps like this to see what channels are being used within range of your smartphone, you can then change your router to use channels that are less congested.

 

I'm not sure what router you have, but be aware that the Sagemcom router has a feature called 'Wi-Fi Optimisation', this means it can change the Wi-Fi channel itself, overriding what you have set it to, it can randomly do this after minutes, hours or days !. So if you do find a channel that works well, but then things go bad again, check to see if the router has changed channel to something different to what you set it to. If you do experience this problem then just post back here to ask the Support Team to disable the 'Wi-Fi Optimisation' on your router, once that is done it will stay on whatever channel you set it to. This only affects the Sagemcom Wi-Fi Hub, if you have the Huawei Wi-Fi Hub it will stay on whatever channel you set it to.

0 Likes

Message 3 of 5

Thanks @Skynet_TX .  I've not changed any router settings and not split passwords on the 2 bands but I will try the router reset.    I have tried manually and with the stored settings, and with the wps button.

I'll update my community profile now.  Thanks for the help!

Claire Darwin

Skynet_TX
Community Star
Message 4 of 5

Hi @Darwinc,

 

Contact details can be found here : https://community.talktalk.co.uk/t5/Articles/Ways-of-contacting-us/ta-p/2230529

 

For one of the TalkTalk Support Team on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile (only you and the TalkTalk Support Team on this community can see your profile details).

 

Then they will hopefully be able to respond to this post tomorrow.

 

Have you updated any settings in your router to split SSID's or anything like that ?


Have you tried providing the SSID / password manually, rather than letting the device use the details that have been saved by Amazon ?

 

You could try a factory reset of the router by holding in the reset switch on the back for over 10 seconds, just wondering if it somehow has different passwords set for the 2.4GHz and 5GHz bands, a factory reset should return the passwords back to the one shown on the label on the back (underneath the pull out plastic card).

0 Likes