Broadband help

For queries about your TalkTalk broadband service.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Intermittent wifi

Team Player
Message 10 of 10



Over the last 2-3 weeks, our wifi has been intermittent in rooms away from the kitchen, where the router is based. Sometimes it works well, but other times the connection is dropped. Normally, the wifi is good upstairs with the aid of an extender, and good in downstairs rooms including the kitchen. Now it is intermittent in all rooms away from the kitchen, sometimes ok, sometimes non-existent.

I think it is the wifi signal rather than the internet supply to the house as TalkTalk TV via extenders through the wiring has been working well.


Any ideas? One recent change in our house has been that the fridge has been replaced-could this be anything to do with it?


When I looked at devices connected to the router, there seemed to be some devices I couldn't identify eg 62:32:B1:06:42:D5 which didn't have an IP address. Does anyone know what this could be, or how I can find out?


Thanks for any ideas about this.


Message 1 of 10

Hi Perplexed1


Please let us know how you get on.






Message 2 of 10

Thanks for your explanations about this, it really helps to improve my understanding of how wifi works. Most likely I will change the channel on the 2.4 signal soon, and then keep it under observation, as you suggest.

Community Star
Message 3 of 10

When the router initially powers up it will pick the best Wi-Fi channel that it can at that moment, so it is quite possible that the channels did change when you switched it off and on. It is possible that some time later the Wi-Fi optimisation might then make a bad decision and flip the channel to something worse !.


There is no real harm in you changing the channel, you can always just change it back to the original setting it is on now if you want to, and as a last resort there is always the pinhole reset switch on the back of the router, holding that in for over 10 seconds will return all settings back to their factory defaults.


5Ghz has a much shorter range that 2.4GHz, so it is less likely that a neighbours router will interfere with your 5GHz signal as that signal will often struggle to reach much beyond the house the router is in, but the 2.4GHz signal will travel much further, so it is far more common to suffer from interference on 2.4GHz.


The key thing with the Sagemcom is to keep an eye on the channel, as due to the 'Wi-Fi Optimisation' the router could just randomly change the channel to a different one.


If you have read up on how to make the change, and you are comfortable to change it, then it would be well worth giving it a go just to see if it does help, and if Wi-Fi Optimisation does undo your work then the staff here could disable that for you.


Changing channel is a perfectly normal thing for customers to do, and it is often recommended by the staff here to troubleshoot Wi-Fi issues. If you do find that selecting a different channel helps, then I would suggest you do get the staff here to turn off the optimisation, as that is the only way you can ensure your router will stay on that good channel.


Totally understand if you would prefer to wait for an official answer from @Debbie-TalkTalk though, the staff here only work UK office hours, but will hopefully be able to respond tomorrow.

Message 4 of 10
No don't turn off the WiFi optimisation just now, thanks.
According to Wifi analyser, I could benefit from changing the 2.4G signal to a different channel, but the 5G signal seems ok as it is.
This morning, I couldn't get a signal when I wanted to stream something. Eventually, I turned off the router briefly, and when the wifi came back on it worked fine. Would that have been the router re-optimising the channels?
Do you advise that I change the 2.4 G channel?
What is your view of turning off WiFi optimisation?

Message 5 of 10

Hi Perplexed1


Sorry for the delay.


Would you like me to switch off the WIFI optimisation to see how the connection compares?





Message 6 of 10

Thanks for advice about 'Wifi Optimisation'.  I will bear that in mind when I get into discussion with TalkTalk about changing channels. 

Community Star
Message 7 of 10

The staff here should be able to take a look at your router, and I think they will be able to see if there are conflicting Wi-Fi channels, so hopefully they will be able to offer more help tomorrow.


If they do find that there is other traffic on conflicting channels, and change your router to use a different channel, then be aware that the Sagemcom router has a 'feature' called 'Wi-Fi Optimisation', this means it can change the Wi-Fi channel itself (it would do this to attempt to pick a better channel, but can sometimes make bad decisions !), overriding what you (or the staff) have set it to, it can randomly do this after minutes, hours or days !. So if you do find a channel that works well, but then things go bad again, check to see if the router has changed channel to something different to what you (or the staff) set it to. If you do experience this problem then just post back here to ask the staff to disable the 'Wi-Fi Optimisation' on your router, once that is done it will stay on whatever channel it is manually set to.


Message 8 of 10

Hi. Thanks for your response. The router is SAGEMCOM. Thanks for pointing out the possibility that it could a problem deriving from a neighbour's wifi.  I haven't tried changing channels on the router as don't feel that confident about doing it. I will read up on it and look forward to Talk Talk staff getting in touch as you say.

Community Star
Message 9 of 10

Hi @Perplexed1,


It might not be something in your home that has changed, if a neighbour has set up a router that is broadcasting on the same, or similar, channel to yours then that could interfere with your signal.


What make of router do you have ?


You could try changing the channels that your router broadcasts the Wi-Fi signal on, you can use free smartphone Apps like this to see what channels are being used within range of your smartphone, you can then change your router to use channels that are less congested.


The TalkTalk staff on this community will be able to help, they will hopefully be able to respond to this post tomorrow.