Showing results for 
Show  only  | Search instead for 
Did you mean: 

email support

Ask us about your TalkTalk email account and Webmail.

Out going mail server

First Timer
Private Message TalkTalk
Message 4 of 4

Cannot connect to outgoing mail server for my email address.

connection to outgoing server failed


Message 1 of 4

Hi leckersley, can you confirm that you've changed to the correct settings and your mail is now working normally?



Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Community Star
Private Message TalkTalk
Message 2 of 4

The outgoing server host name for all TalkTalk Mail domains (including all from the family) is and the outgoing port number is 587 using the connection security StartTLS with the normal email password for the sending address to authenticate the server connection. 


Please ensure you are using an up to date email client and device Operating system and then correct the incoming and outgoing server settings. If you need help with a specific device or email client then I'll need to know exactly what device and software version is in use for both the Operating System and email client software.


Heads up that there is planned email maintenance scheduled for overnight tonight.


The TalkTalk Mail Support Hub is your go to resource for information, guides and Community support for TalkTalk Consumer home broadband and MailPlus subscribers.


Select here:
TalkTalk Mail Support


TalkTalk Mail help
Using TalkTalk Mail

Changing your email password

Email settings and device setup guides for TalkTalk Mail

GondolaCommunity Star 2017-2024

  Like below to appreciate my post . . . Mark as solved  Accept as Solution

Support Team
Private Message
Message 3 of 4



Apologies for this.


Can I just check, are you using webmail or an email client?


Would it be possible to post a screenshot of the error message you are receiving?


Could you also confirm your user settings for SMTP?