Showing results for 
Show  only  | Search instead for 
Did you mean: 

FIbre Support

Get expert support with your Fibre connection.

I can't Connect my 2.4Ghz BBQ Thermometer To Eero Router

Whizz Kid
Private Message TalkTalk
Message 5 of 5

Good evening.

Sun's out so it's BBQ time.

I have an Inkbird IBBQ-4T WiFi BBQ thermometer which works on the 2.4Ghz band. Before going full-fibre, I had two networks with different named SSIDs for the 5Ghz and 2.4Ghz bands. So, when I wanted to use the IBBQ-4T I selected the 2.4Ghz network to connect the thermometer's app on my iPhone. My full-fibre setup has only one SSID and try as I might, I cannot connect the thermometer app. I also have a video doorbell that works on the 2.4Ghz band and this connects automatically. To confirm, I have client steering switched on my Eero router.

It's not the end of the World but, I'd like to know if I've missed something obvious. Thank you.

Full Fibre 150

Message 1 of 5



Ok, thanks for the update.





Message 2 of 5

Hi Michelle.

I've had a go at disabling the 5G network etc. as instructed but, I still can't get the thing connected. I used to have a bit of trouble with the app which I think is a bit flaky so, I'm not going to bother with it anymore. Thank you for your kind assistance.

Kind regards,


Full Fibre 150

Support Team
Private Message
Message 3 of 5



How are you getting on?






Community Star
Private Message TalkTalk
Message 4 of 5

First, make sure Legacy mode is enabled in the Eero app.


When a 2.4GHz device has to be connected via its own app, this can cause problems, as both the 2.4 & 5GHz bands share the same network name (SSID). The Eero does not permit the use of split SSID names, as it sounds like you have found out already


Now turn off the devices in question.


Then make sure that WPA3 is disabled (operating in transition mode this should not be necessary, but it is classed as beta). To do this in the Eero app, go to:-


Advanced settings tap on Discover > Eero labs beta feature and turn off WPA3.

Next temporarily turn off the 5GHz band, this is done by going to:-


Settings > Troubleshooting > My device is 2.4 GHz only and tap Temporarily Pause 5 GHz.


There is now a 10 minute window to turn on the devices back on again.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?