FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MS Remote Desktop over OpenVPN

gh2609
Popular Poster
Message 28 of 28

Here’s the problem:

I have a Sagem router (TalkTalk supplied) and via WiFi connection, trying to use MS Remote Desktop over OpenVPN with an iPhone. This works very well via a Windows 10 laptop, desktop and Android tablet, but will not work with the iPhone. I tried three separate iPhones, all of which will connect to OpenVPN server using iPhone OpenVPN client, but then get no response trying to connect using MS Remote Desktop client.

 

The iPhones will however connect through OpenVPN and MS Remote Desktop via a cellular connection. 

As a further diagnostic step, I also temporarily changed router to one previously supplied by TalkTalk (D-Link), but this gave exactly the same result.

 

I even tried to connect using iPhone at another property using TalkTalk, but this also failed.


In every case using the iPhone, a ping or traceroute to the Remote Desktop host returns no response, even though an OpenVPN connection has been established.

 

Any ideas will be much appreciated.

0 Likes
27 REPLIES 27

Message 1 of 28

Hi gh2609,

 

Glad to hear it working again. As far as I'm aware nothing has changed at our end but I'll check to see if our Product Team have made any adjustments


Chris

Message 2 of 28

Hi Chris,

 

Im not sure what has occurred since my previous post within this thread (Thursday 03/12/20), but the issue of connecting to my workplace using MS RD over OpenVPN while using an IPhone/iPad over TT fibre started functioning within hours following my previous post.

I have checked the Apple App Store and the most recent update relates to the MS RD App, which was one week ago. So still puzzled as to why this has been an issue for weeks and since Thursday evening, it now isn’t.

 

I have tested the connection many times within the last 40 hours with no problems to report.

 

Your thoughts on this will be much appreciated, as not knowing what the issue was and the fact that it appears to have fixed itself, does not give me confidence going forward.

 

GH2609

 

0 Likes

Chris-TalkTalk
Support Team
Message 3 of 28

Hi gh2609,

 

We've not received an update yet, can you bump the thread on Monday and we'll check again 


Chris

0 Likes

Message 4 of 28

I haven’t contacted Apple as the iPhones and iPads connect ok over other domestic ISP fibre connections and cellular also. I also use Apple devices at work over WiFi via leased fibre lines, without problems.
As I have pointed out numerous times previously within this thread, the issue is specific to TalkTalk and no traffic from the OpenVPN client is getting passed the TalkTalk router, even though the OpenVPN client status states ‘Connected’, i.e. trace route to any address outside of the LAN stops at the router.

Please advise on a fix for this as I do require this for my work. My contract with TalkTalk is due for renewal shortly, so if this can’t be fixed, please let me know and I will look at alternatives that support this connectivity.

0 Likes

Message 5 of 28

Hi, thanks for the suggestion, however I have been using the ‘OpenVPN Connect’ app since initial  setup. The app functions perfectly when using iPhone over a Virgin fibre or Plusnet cellular connection; it’s only the combination of iPhone using TalkTalk fibre that is the issue. As an example, I can drive to a family member’s home and connect to their WiFi (Virgin fibre), then connect to my workplace via OpenVPN client without issue. 

0 Likes

Message 6 of 28
I haven’t contacted Apple.
0 Likes

Message 7 of 28
0 Likes

Message 8 of 28

Hi Glen,

 

Our Products Team have asked if you have also contacted Apple about this and if they made any suggestions?

 

Thanks

 

0 Likes

Message 9 of 28

Hi Glen,

 

I've passed this over to our Products Team now and will post back as soon as they come back to me.

 

Thanks

 

0 Likes

Message 10 of 28

@KeithFrench - My apologies, I completely missed that, my bad. I'll take another look now.

 

Thanks

 

0 Likes

Message 11 of 28

Hi @Michelle-TalkTalk 

 

I already said in post #8 that was very little I could do to help as I do not have any Apple products. Perhaps @ferguson might be able to help, due to his experience with these products.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 12 of 28

Hi,

 

@KeithFrench - Would you be able to offer any advice?

 

Thanks

 

Message 13 of 28

Hi Debbie,

 

I haven’t got a problem connecting via TalkTalk fibre using Wi-Fi or Ethernet (wired) with any device other than an iPhone or iPad, which I am now required to use when working from home. I’m guessing there is something fundamentally at odds with this combination, as I previously tested the same Apple devices using other ISP’s (Virgin) fibre connection, which does not have an issue.

 

Please let me know your thoughts on the above situation.

 

Regards

 

Glen

 

 

0 Likes

Message 14 of 28

Hi Glen

 

Apologies for this.

 

Would it be possible to connect wired? (just for testing purposes)

 

Thanks

 

Debbie

0 Likes

Message 15 of 28

Hi Michelle,

 

On receipt of the replacement router, I connected and powered up with the config as delivered, i.e. 2.4 and 5 GHz bands sharing the same SSID. I then tested connecting to my workplace using MS RD client over OpenVPN client on iPhone. As per previous attempts with the original router, this failed. I then split the 2.4 and 5 GHz bands to have separate SSID’s, as this is how I had the previous router configured. This change did not make any difference to the connectivity issue.

 

Looking forward to your advice on this matter.

 

Regards

 

Glen

0 Likes

Michelle-TalkTalk
Support Team
Message 16 of 28

Morning,

 

Thanks for the update. Have you tried separating the SSID's on the replacement router and then retested again?

 

Split your router's SSID (wireless network name)

 

Thanks

 

Message 17 of 28

Hi Debbie,

 

I received the Huwawei router and swapped out the Sagecom. The issue with MS RD client over OpenVPN connection using iPhone over TalkTalk fast fibre connection still exists. It’s proving to be difficult to resolve as all other client devices (MS Windows and Android) using TalkTalk fibre do not exhibit the same behaviour. Strangely the iPhones, of which I tried 3 models, have no issue when connected through a Virgin and Plusnet fibre connection.

 

On a positive, the Huwawei router appears to have a slight edge over the Sagecom with respect to latency values recorded during testing. The Huwawei is noticeably faster on browser page refresh and this bears out when running persistent ping tests.

 

So still clueless as to what the issue may be.

 

Looking forward to your comments.

 

0 Likes

Message 18 of 28

Hi Glen

 

The Huawei WIFI Hub is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 19 of 28

Hi Debbie,

 

Thank you for getting back to me on this matter. As per your suggestion, I’ll try the new hub and test to see if that fixes the issue.

 

Regards

 

Glen Hewitt

Debbie-TalkTalk
Support Team
Message 20 of 28

Hi gh2609

 

Would you like me to send the new Huawei WIFI Hub for testing first, to see how the connection compares?

 

Thanks

 

Debbie