cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NEED SOME HELP?

We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

Apple devices are connected to eero but no WiFi

Somsrc
Sightseer
Private Message TalkTalk
Message 10 of 10

We had a power cut two days ago and since then our  Apple devices are struggling to pick up a WiFi signal. They say connected to the network but there’s no internet connection on the device.

 

All non-apple devices are working fine.

 

thanks in advance for any help

0 Likes
9 REPLIES 9

Message 1 of 10

Morning,

 

Please let us know how you get on and if you need any assistance.

 

Thanks

 

Michelle

 

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 2 of 10

Sounds likely then @Somsrc 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 3 of 10

OK, let us know how you get on when the new eero arrives. 

0 Likes

Somsrc
Sightseer
Private Message TalkTalk
Message 4 of 10

Thanks both.

 

Whilst the Apple devices aren’t connecting, there’s a wider issue with the connection as it keeps going down intermittently for non- Apple devices.

 

i think the issue is the eero router as when I run speed tests on the app it  is showing 150mbps. I’m getting a new one sent out as I think the power cut has done something to it. I’ve done multiple resets of the router and whilst it works for a short time it then becomes temperamental again.

 

hopefully this fixes the issues.

 

 

KeithFrench
Community Star
Private Message TalkTalk
Message 5 of 10

With this only affecting your Apple products, the issue would appear to be with the iPhones themselves. if the suggestion from@ferguson does not work, try turning each of these off for a couple of minutes & try reconnecting. Ferguson knows much more about iPhones than I do.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 6 of 10

Try turning off your iPhone mobile data connection temporarily and see what happens. 

0 Likes

Message 7 of 10

Sadly rebooting the eero hasn’t worked.

 

My iPhone actually connected when I first turned the router back on but then disappeared when I tried to use safari. I’ve included a screenshot showing my phone saying it’s connected but you can see it’s using my 5g phone network 

 

Any other solutions you could recommend?


709B2D19-03D9-4050-9989-CBD38848A619.jpeg
0 Likes

Somsrc
Sightseer
Private Message TalkTalk
Message 8 of 10

Hi Keith. I have one eero. When I go on the eero app it says the apple devices are connected and when I got into the WiFi section of my iPhone the WiFi network of my eero has a tick.

 

It’s strange as every non apple device is connected with no issues.

 


I’ll turn the eero off for 30 mins and try again.

 

thanks

0 Likes

KeithFrench
Community Star
Private Message TalkTalk
Message 9 of 10

How many eeros do you have, what does the app say about the Gateway Eero? If they are struggling to get a WiFi signal, how are they connected? I would first start by turning the eero & ONT off for at least 30 mins & retesting.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes