cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NEED SOME HELP?

We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

No white light on router but internet works ok

TrixieRa
Team Player
Private Message TalkTalk
Message 9 of 9

For sometime now the white light does not work on my GD8041W, but the starting up process does light up.

 

I called and reported it, and after spending a long time going through tests (most of which I had already done), I was told that as long as it still worked, they would not replace it!

 

That is so annoying, as it's such a simple thing, and it's reassuring to have that light, but why is it denied?

 

Has anybody else had that problem?

 

 

0 Likes
8 REPLIES 8

Message 1 of 9

Hi AdilJ1

 

Please can you create a new topic on the Community, we can then take a look at this for you.

 

Thanks

0 Likes

Message 2 of 9

If you need further help, @AdilJ1, please start your own topic and staff will reply during the week. 

 

You'll also need to complete your community forum profile details for TT staff to identify your account. 

Gliwmaeden2, a fellow customer.

AdilJ1
Newbie
Private Message TalkTalk
Message 3 of 9

I seem to have the same problem, although going through the diagnostics was difficult on a phone and terminated early with a survey which I responded to appropriately.  I still have no white light on the router but internet access seems OK.

0 Likes

Message 4 of 9

Hi @TrixieRa 

 

That's great, thanks for letting us know 🙂

 

I have sent you a Private Message with a link to a short survey for the Community.

 

Thanks again.

 

Debbie

0 Likes

TrixieRa
Team Player
Private Message TalkTalk
Message 5 of 9

Thanks Debbie,

The replacement arrived today and was working within 15 mins.

I will send the faulty one back within the next day or two.

Again, thanks for your prompt help and support.

 

regards

 

TR

Message 6 of 9

Hi TrixieRa

 

Apologies for this.

 

The replacement router is on its way and a returns bag for your current one.

 

Please allow 24-48hrs for this to arrive. Let us know how you get on.

 

Thanks

 

Debbie

0 Likes

TrixieRa
Team Player
Private Message TalkTalk
Message 7 of 9

Yes please Debbie,

At last you have understood and solved the problem.

I was told it was not a fault and I would have to pay!

 

Thanks again.

Debbie-TalkTalk
Support Team
Staff
Private Message
Message 8 of 9

Hi TrixieRa

 

This will be a fault with the router, would you like me to send a replacement router?

0 Likes