Showing results for 
Show  only  | Search instead for 
Did you mean: 

Broadband help

For queries about your TalkTalk broadband service.

Cannot stream bbc iplayer or podcasts or login to talktalk account unless i activate vpn.

First Timer
Private Message TalkTalk
Message 5 of 5

Since last week I am unable to get to or stream iplayer content unless I activate vpn. This is on all devices.


Router has been restarted and I have changed DNS from talktalk's to Google's but it makes no difference.


First Timer
Private Message TalkTalk
Message 1 of 5

Most questions like these never seem to get a satisfactory conclusion posted to a forum. So, just to totally close this one down and to add a warning to everyone. I run a raspberry pi as a simple web server and cctv camera system. As this pi is not normally visible to the internet it runs defaults.


Rule 1. Always, always change the defaults regardless of how safe you think you are.


Anyway, I temporarily opened up port forwarding on the router for SCP to test some file transfer software; the port was open for just a few minutes but this was long enough for an automated bot to find my pi and install itself into the local RC folder as well as changing the user pi password and then rebooted to become a new bot.


The bot code uses zmap to continually scan the internet looking for open raspberry pi machines. That's bad enough but as a side effect it uses up all the router's available ip sockets which caused the symptoms I was seeing.


Once the problem was identified it was simple to clear up.


So , moral of this is ALWAY change your defaults and think carefully of the ramifications of opening up your home network to the internet.




Message 2 of 5



I'm glad to hear that streaming services are now working correctly for you with the new IP Range.




Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips

Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Message 3 of 5

Just to close the loop on this one. The dynamic DNS and reverse DNS all were resolving correctly, the router address was in the range when all streaming services were blocked/unreachable.


After powering the router down for 60 minutes the router was issued a new ip in the range and now the streaming services have returned.


It would appear that a periodic restart is beneficial.


We can call this case closed.


Support Team
Private Message
Message 4 of 5

Good morning,


I'm sorry to hear this. Can I just confirm have you also tried powering down the router for a full 30 minutes as this will reset the current session?