Showing results for 
Show  only  | Search instead for 
Did you mean: 

Broadband help

For queries about your TalkTalk broadband service.

Router Keeps Channel hoping

Conversation Starter
Private Message TalkTalk
Message 6 of 6

I want my 5Ghz Chanel to be set to 40, when I change the router settings to channel 40, a couple of hours it resets itself to  the default 44. As 9 other routers are on Channel 44, I want to be on 40 as I would be the only one. I’ve had two chat calls today and one aborted phone call where after the person answered the call they left me hanging on for 20 minutes and no joy. Does any one know how I can decide when channel I want to be on and not have it changed back to the default.


Message 1 of 6

Hi walle1j


I'm so glad to hear this 🙂


Apologies that this issue wasn't resolved when contacting our Faults Team previously.


I have sent you a Private Message with a link to a short survey for the Community.


Thanks again.




Message 2 of 6

Thanks Debbie,


What every the other people on Chat or by phone tried to do - it didnt work.  But you have managed it and it's appreciated.  So far no more channel hoping.🤗


Support Team
Private Message
Message 3 of 6

Hi walle1j


I have switched the WIFI optimisation off, please let us know how the connection compares.





Conversation Starter
Private Message TalkTalk
Message 4 of 6



Thank you for the explaination,  It makes sence as I do have a Sagemcom hub.  I have requested wifi optimisation be switched off.    Hopefully my chanell will stay put. 🤞


Community Star
Private Message TalkTalk
Message 5 of 6

This sounds like you might have one of the Sagemcom hubs, if you have you will need to request Wi-Fi Optimisation to be disabled.


However, the way that WiFi interference is dealt with in the 5GHz is different to the 2.4Ghz band. It will never give you exclusive use of which channel you set in each group (36 - 48). Take the one you mention, whichever channel you set it to in that group, the router will try & use at first. However, if it detects other routers using (say 40 in your example), then it will try & use another channel in that same group & you might find it on perhaps 48. Then if that channel is congested, it might move to 36. Then channel bandwidth needs to be considered, if someone is transmitting enough data to warrant 80MHz bandwidth, that router will try & use all four channels. All routers will try and manage the bandwidth to give everyone some degree of service. You cannot change this behaviour, as it is the way every router or AP works in the 5GHz band.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?